aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorAvuton Olrich <avuton@gmail.com>2010-09-11 20:06:05 -0700
committerAvuton Olrich <avuton@gmail.com>2010-09-11 20:06:05 -0700
commita3745ae7f3330454a17ca4ad2c7c422d373a2325 (patch)
tree3ea96206452b384ac787e23c935f605ce5bd6010 /configure.ac
parent27d7013ff87e80fa5f94c384c41027f3a54f90c2 (diff)
downloadmpd-a3745ae7f3330454a17ca4ad2c7c422d373a2325.tar.gz
mpd-a3745ae7f3330454a17ca4ad2c7c422d373a2325.tar.xz
mpd-a3745ae7f3330454a17ca4ad2c7c422d373a2325.zip
configure.ac: Correct and clean up tremor check in oggvorbis test.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 5 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 02d860b14..68f40190e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -970,8 +970,11 @@ fi
AM_CONDITIONAL(HAVE_OGGFLAC, test x$enable_oggflac = xyes)
dnl -------------------------------- Ogg Vorbis -------------------------------
-if test x$enable_tremor != xno && test x$enable_vorbis = xyes; then
- if test x$enable_ogg = xyes; then
+if test x$enable_vorbis = xyes; then
+ if test x$use_tremor = xyes; then
+ AC_MSG_WARN(["OggTremor detected, could not enable Vorbis."])
+ enable_vorbis=no
+ elif test x$enable_ogg = xyes; then
PKG_CHECK_MODULES(VORBIS, [vorbis vorbisfile],
AC_DEFINE(ENABLE_VORBIS_DECODER, 1, [Define for Ogg Vorbis support]),
enable_vorbis=no)