aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorAvuton Olrich <avuton@gmail.com>2009-02-28 07:50:13 -0800
committerAvuton Olrich <avuton@gmail.com>2009-02-28 07:50:13 -0800
commita31f3c89fbdfb2ffb55a8a0ebba7f7a469d6fc43 (patch)
tree4984e151e283382bdf4608a22ab9705adec211f7 /configure.ac
parent374e090985058eec8839b16d449ef67394494fb6 (diff)
downloadmpd-a31f3c89fbdfb2ffb55a8a0ebba7f7a469d6fc43.tar.gz
mpd-a31f3c89fbdfb2ffb55a8a0ebba7f7a469d6fc43.tar.xz
mpd-a31f3c89fbdfb2ffb55a8a0ebba7f7a469d6fc43.zip
configure: move the configure status stuff in alphabetical order.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac210
1 files changed, 105 insertions, 105 deletions
diff --git a/configure.ac b/configure.ac
index 118f1d492..fa08c4574 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1177,18 +1177,18 @@ echo "########### MPD CONFIGURATION ############"
echo ""
echo " Client Support:"
-if test x$enable_tcp = xyes; then
- echo " TCP support ...................enabled"
-else
- echo " TCP support ...................disabled"
-fi
-
if test x$enable_ipv6 = xyes; then
echo " IPv6 support ..................enabled"
else
echo " IPv6 support ..................disabled"
fi
+if test x$enable_tcp = xyes; then
+ echo " TCP support ...................enabled"
+else
+ echo " TCP support ...................disabled"
+fi
+
if test x$enable_un = xyes; then
echo " Unix domain socket support ....enabled"
else
@@ -1204,30 +1204,36 @@ if
fi
echo " Playback Support:"
-if test x$enable_ao = xyes; then
- echo " libao support .................enabled"
-else
- echo " libao support .................disabled"
-fi
-
-if test x$enable_oss = xyes; then
- echo " OSS support ...................enabled"
-else
- echo " OSS support ...................disabled"
-fi
-
if test x$enable_alsa = xyes; then
echo " ALSA support ..................enabled"
else
echo " ALSA support ..................disabled"
fi
+if test x$enable_fifo = xyes; then
+ echo " FIFO support ..................enabled"
+else
+ echo " FIFO support ..................disabled"
+fi
+
if test x$enable_jack = xyes; then
echo " JACK support ..................enabled"
else
echo " JACK support ..................disabled"
fi
+if test x$enable_ao = xyes; then
+ echo " libao support .................enabled"
+else
+ echo " libao support .................disabled"
+fi
+
+if test x$enable_oss = xyes; then
+ echo " OSS support ...................enabled"
+else
+ echo " OSS support ...................disabled"
+fi
+
if test x$enable_osx = xyes; then
echo " OS X support ..................enabled"
else
@@ -1246,12 +1252,6 @@ else
echo " PulseAudio support ............disabled"
fi
-if test x$enable_fifo = xyes; then
- echo " FIFO support ..................enabled"
-else
- echo " FIFO support ..................disabled"
-fi
-
if test x$enable_mvp = xyes; then
echo " Media MVP support .............enabled"
else
@@ -1287,33 +1287,22 @@ fi
echo " File Format Support:"
-if test x$enable_id3 = xyes; then
- echo " ID3 tag support ...............enabled"
-else
- echo " ID3 tag support ...............disabled"
-fi
-
-if test x$enable_mp3 = xyes; then
- echo " mp3 support ...................enabled"
+if test x$enable_aac = xyes; then
+ echo " AAC support ...................enabled"
else
- echo " mp3 support ...................disabled"
+ echo " AAC support ...................disabled"
fi
-if test x$enable_lame = xyes; then
- echo " lame support ..................enabled"
+if test x$enable_sidplay = xyes; then
+ echo " C64 SID support ...............enabled"
else
- echo " lame support ..................disabled"
+ echo " C64 SID support ...............disabled"
fi
-if test x$enable_oggvorbis = xyes; then
- echo " Ogg Vorbis support ............enabled"
- if test x$use_tremor = xyes; then
- echo " using tremor.................yes"
- else
- echo " using tremor.................no"
- fi
+if test x$enable_ffmpeg = xyes; then
+ echo " FFMPEG support ................enabled"
else
- echo " Ogg Vorbis support ............disabled"
+ echo " FFMPEG support ................disabled"
fi
if test x$enable_flac = xyes; then
@@ -1322,28 +1311,40 @@ else
echo " FLAC support ..................disabled"
fi
-case $enable_oggflac in
-yes)
- echo " OggFLAC support ...............enabled"
- ;;
-flac)
- echo " OggFLAC support ...............enabled(FLAC 1.1.3)"
- ;;
-*)
- echo " OggFLAC support ...............disabled"
- ;;
-esac
+if test x$enable_fluidsynth = xyes; then
+ echo " fluidsynth MIDI support .......enabled"
+else
+ echo " fluidsynth MIDI support .......disabled"
+fi
-if test x$enable_audiofile = xyes; then
- echo " Wave file support .............enabled"
+if test x$enable_id3 = xyes; then
+ echo " ID3 tag support ...............enabled"
else
- echo " Wave file support .............disabled"
+ echo " ID3 tag support ...............disabled"
fi
-if test x$enable_aac = xyes; then
- echo " AAC support ...................enabled"
+if test x$enable_lame = xyes; then
+ echo " lame support ..................enabled"
else
- echo " AAC support ...................disabled"
+ echo " lame support ..................disabled"
+fi
+
+if test x$enable_mod = xyes; then
+ echo " MOD support ...................enabled"
+else
+ echo " MOD support ...................disabled"
+fi
+
+if test x$enable_modplug = xyes; then
+ echo " MODPLUG support ...............enabled"
+else
+ echo " MODPLUG support ...............disabled"
+fi
+
+if test x$enable_mp3 = xyes; then
+ echo " mp3 support ...................enabled"
+else
+ echo " mp3 support ...................disabled"
fi
if test x$enable_mp4 = xyes; then
@@ -1358,34 +1359,39 @@ else
echo " Musepack (MPC) support ........disabled"
fi
-if test x$enable_wavpack = xyes; then
- echo " WavPack support ...............enabled"
-else
- echo " WavPack support ...............disabled"
-fi
-
-if test x$enable_mod = xyes; then
- echo " MOD support ...................enabled"
-else
- echo " MOD support ...................disabled"
-fi
+case $enable_oggflac in
+yes)
+ echo " OggFLAC support ...............enabled"
+ ;;
+flac)
+ echo " OggFLAC support ...............enabled(FLAC 1.1.3)"
+ ;;
+*)
+ echo " OggFLAC support ...............disabled"
+ ;;
+esac
-if test x$enable_modplug = xyes; then
- echo " MODPLUG support ...............enabled"
+if test x$enable_oggvorbis = xyes; then
+ echo " Ogg Vorbis support ............enabled"
+ if test x$use_tremor = xyes; then
+ echo " using tremor.................yes"
+ else
+ echo " using tremor.................no"
+ fi
else
- echo " MODPLUG support ...............disabled"
+ echo " Ogg Vorbis support ............disabled"
fi
-if test x$enable_sidplay = xyes; then
- echo " C64 SID support ...............enabled"
+if test x$enable_audiofile = xyes; then
+ echo " Wave file support .............enabled"
else
- echo " C64 SID support ...............disabled"
+ echo " Wave file support .............disabled"
fi
-if test x$enable_fluidsynth = xyes; then
- echo " fluidsynth MIDI support .......enabled"
+if test x$enable_wavpack = xyes; then
+ echo " WavPack support ...............enabled"
else
- echo " fluidsynth MIDI support .......disabled"
+ echo " WavPack support ...............disabled"
fi
if test x$enable_wildmidi = xyes; then
@@ -1394,11 +1400,7 @@ else
echo " wildmidi MIDI support .........disabled"
fi
-if test x$enable_ffmpeg = xyes; then
- echo " FFMPEG support ................enabled"
-else
- echo " FFMPEG support ................disabled"
-fi
+
if
test x$enable_mp3 = xno &&
@@ -1427,34 +1429,20 @@ else
echo " BZ2 archives support ..........disabled"
fi
-if test x$enable_zip = xyes; then
- echo " ZIP archives support ..........enabled"
-else
- echo " ZIP archives support ..........disabled"
-fi
-
if test x$enable_iso = xyes; then
echo " ISO 9660 archives support .....enabled"
else
echo " ISO 9660 archives support .....disabled"
fi
-echo ""
-echo " Other features:"
-
-if test x$enable_lsr = xyes; then
- echo " libsamplerate support .........enabled"
-else
- echo " libsamplerate support .........disabled"
-fi
-
-
-if test x$with_zeroconf != xno; then
- echo " Zeroconf support ..............$with_zeroconf"
+if test x$enable_zip = xyes; then
+ echo " ZIP archives support ..........enabled"
else
- echo " Zeroconf support ..............disabled"
+ echo " ZIP archives support ..........disabled"
fi
+echo ""
+echo " Other features:"
if test x$enable_curl != xno; then
echo " HTTP streaming (libcurl) ......enabled"
@@ -1462,12 +1450,24 @@ else
echo " HTTP streaming (libcurl) ......disabled"
fi
+if test x$enable_lsr = xyes; then
+ echo " libsamplerate support .........enabled"
+else
+ echo " libsamplerate support .........disabled"
+fi
+
if test x$enable_mms != xno; then
echo " MMS streaming (libmms) ........enabled"
else
echo " MMS streaming (libmms) ........disabled"
fi
+if test x$with_zeroconf != xno; then
+ echo " Zeroconf support ..............$with_zeroconf"
+else
+ echo " Zeroconf support ..............disabled"
+fi
+
echo ""
echo "##########################################"
echo ""