aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2014-01-20 23:21:48 +0100
committerMax Kellermann <max@duempel.org>2014-01-20 23:31:08 +0100
commita237e7f860bb4705823077e90b2ecc599746e46c (patch)
tree9eb68c4472459472258c9d3edf7417ddc6163fdc /configure.ac
parent07a3bef25ca737bccb04d2d8d16923ddd2ab162b (diff)
downloadmpd-a237e7f860bb4705823077e90b2ecc599746e46c.tar.gz
mpd-a237e7f860bb4705823077e90b2ecc599746e46c.tar.xz
mpd-a237e7f860bb4705823077e90b2ecc599746e46c.zip
CommandLine: show the current git tag and commit id
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 71fdb0e1d..52db236ba 100644
--- a/configure.ac
+++ b/configure.ac
@@ -15,6 +15,10 @@ AC_CONFIG_MACRO_DIR([m4])
AC_DEFINE(PROTOCOL_VERSION, "0.19.0", [The MPD protocol version])
+GIT_COMMIT=`GIT_DIR="$srcdir/.git" git describe --dirty --always 2>/dev/null`
+if test x$GIT_COMMIT != x; then
+ AC_DEFINE_UNQUOTED(GIT_COMMIT, ["$GIT_COMMIT"], [The current git commit])
+fi
dnl ---------------------------------------------------------------------------
dnl Programs