aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2009-12-31 11:11:14 +0100
committerMax Kellermann <max@duempel.org>2009-12-31 15:50:59 +0100
commita0384aaead1427e9f7bd3643c4149371d687e53d (patch)
tree7a60322cedc1fb3af7c01ad773053ea2fe33f7a9 /configure.ac
parentefc885a9dc2e6632ca2a24a0ff52ab51bb1d82d1 (diff)
downloadmpd-a0384aaead1427e9f7bd3643c4149371d687e53d.tar.gz
mpd-a0384aaead1427e9f7bd3643c4149371d687e53d.tar.xz
mpd-a0384aaead1427e9f7bd3643c4149371d687e53d.zip
Makefile.am: added unit tests for the archive plugins
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac18
1 files changed, 18 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index d2313a654..c45574b0b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -353,8 +353,14 @@ fi
AM_CONDITIONAL(HAVE_BZ2, test x$enable_bzip2 = xyes)
if test x$enable_bzip2 = xyes; then
AC_DEFINE(HAVE_BZ2, 1, [Define to have bz2 archive support])
+
+ AC_PATH_PROG(BZIP2, bzip2, no)
+else
+ BZIP2="no"
fi
+AM_CONDITIONAL(ENABLE_BZIP2_TEST, test x$BZIP2 != xno)
+
dnl zzip
AC_ARG_ENABLE(zzip,
AS_HELP_STRING([--enable-zzip],
@@ -367,8 +373,14 @@ MPD_AUTO_PKG(zzip, ZZIP, [zziplib >= 0.13],
AM_CONDITIONAL(HAVE_ZZIP, test x$enable_zzip = xyes)
if test x$enable_zzip = xyes; then
AC_DEFINE(HAVE_ZZIP, 1, [Define to have zip archive support])
+
+ AC_PATH_PROG(ZIP, zip, no)
+else
+ ZIP="no"
fi
+AM_CONDITIONAL(ENABLE_ZZIP_TEST, test x$ZIP != xno)
+
dnl iso9660
AC_ARG_ENABLE(iso9660,
AS_HELP_STRING([--enable-iso9660],
@@ -381,8 +393,14 @@ MPD_AUTO_PKG(iso9660, ISO9660, [libiso9660],
AM_CONDITIONAL(HAVE_ISO9660, test x$enable_iso9660 = xyes)
if test x$enable_iso9660 = xyes; then
AC_DEFINE(HAVE_ISO9660, 1, [Define to have ISO9660 archive support])
+
+ AC_PATH_PROG(MKISOFS, mkisofs, no)
+else
+ MKISOFS="no"
fi
+AM_CONDITIONAL(ENABLE_ISO9660_TEST, test x$MKISOFS != xno)
+
dnl archive API
if
test x$enable_bzip2 = xyes ||