aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorAvuton Olrich <avuton@gmail.com>2006-07-19 15:54:53 +0000
committerAvuton Olrich <avuton@gmail.com>2006-07-19 15:54:53 +0000
commit9f6364af45c2efb868c0318aff78be913bcc4869 (patch)
treed2329295abe223be5be286b0919ca4226d079d08 /configure.ac
parent9774768b97c8ab432dfbf961f294f77fd2591822 (diff)
downloadmpd-9f6364af45c2efb868c0318aff78be913bcc4869.tar.gz
mpd-9f6364af45c2efb868c0318aff78be913bcc4869.tar.xz
mpd-9f6364af45c2efb868c0318aff78be913bcc4869.zip
Remove the internal mp4ff dependency
git-svn-id: https://svn.musicpd.org/mpd/trunk@4401 09075e82-0dd4-0310-85a5-a0d7c8717e4f
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac76
1 files changed, 38 insertions, 38 deletions
diff --git a/configure.ac b/configure.ac
index 31e775c34..4c5614df4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -13,8 +13,6 @@ AC_SUBST(MAD_SUBDIR)
AC_SUBST(MAD_LIB)
AC_SUBST(ID3_SUBDIR)
AC_SUBST(ID3_LIB)
-AC_SUBST(MP4FF_LIB)
-AC_SUBST(MP4FF_SUBDIR)
AC_SUBST(MPD_LIBS)
AC_SUBST(MPD_CFLAGS)
@@ -352,26 +350,24 @@ if test x$enable_mpc = xyes; then
CPPFLAGS=$oldcppflags
fi
-MP4FF_SUBDIR=""
-
if test x$enable_aac = xyes; then
- if test "x$faad_libraries" != "x" ; then
- FAAD_LIBS="-L$faad_libraries"
- elif test "x$faad_prefix" != "x" ; then
- FAAD_LIBS="-L$faad_prefix/lib"
- elif test "x$prefix" != "xNONE"; then
- FAAD_LIBS="-L$libdir"
- fi
+ if test "x$faad_libraries" != "x" ; then
+ FAAD_LIBS="-L$faad_libraries"
+ elif test "x$faad_prefix" != "x" ; then
+ FAAD_LIBS="-L$faad_prefix/lib"
+ elif test "x$prefix" != "xNONE"; then
+ FAAD_LIBS="-L$libdir"
+ fi
- FAAD_LIBS="$FAAD_LIBS -lfaad"
+ FAAD_LIBS="$FAAD_LIBS -lfaad -lmp4ff"
- if test "x$faad_includes" != "x" ; then
- FAAD_CFLAGS="-I$faad_includes"
- elif test "x$faad_prefix" != "x" ; then
- FAAD_CFLAGS="-I$faad_prefix/include"
- elif test "x$prefix" != "xNONE"; then
- FAAD_CFLAGS="-I$includedir"
- fi
+ if test "x$faad_includes" != "x" ; then
+ FAAD_CFLAGS="-I$faad_includes"
+ elif test "x$faad_prefix" != "x" ; then
+ FAAD_CFLAGS="-I$faad_prefix/include"
+ elif test "x$prefix" != "xNONE"; then
+ FAAD_CFLAGS="-I$includedir"
+ fi
oldcflags=$CFLAGS
oldlibs=$LIBS
@@ -380,6 +376,7 @@ if test x$enable_aac = xyes; then
LIBS="$LIBS $MPD_LIBS $FAAD_LIBS"
CPPFLAGS=$CFLAGS
AC_CHECK_HEADER(faad.h,,enable_aac=no)
+ AC_CHECK_HEADER(mp4ff.h,,enable_aac=no)
if test x$enable_aac = xyes; then
AC_CHECK_DECL(FAAD2_VERSION,,enable_aac=no,[#include <faad.h>])
fi
@@ -387,14 +384,17 @@ if test x$enable_aac = xyes; then
AC_CHECK_DECL(faacDecInit2,,enable_aac=no,[#include <faad.h>])
fi
if test x$enable_aac = xyes; then
- AC_CHECK_LIB(faad,faacDecInit2,[MPD_LIBS="$MPD_LIBS $FAAD_LIBS";MPD_CFLAGS="$MPD_CFLAGS $FAAD_CFLAGS";MP4FF_SUBDIR="mp4ff";MP4FF_LIB="mp4ff/libmp4ff.la"],enable_aac=no)
+ AC_CHECK_LIB(faad,faacDecInit2,[MPD_LIBS="$MPD_LIBS $FAAD_LIBS";MPD_CFLAGS="$MPD_CFLAGS $FAAD_CFLAGS"],enable_aac=no)
if test x$enable_aac = xno; then
enable_aac=yes
- AC_CHECK_LIB(faad,NeAACDecInit2,[MPD_LIBS="$MPD_LIBS $FAAD_LIBS";MPD_CFLAGS="$MPD_CFLAGS $FAAD_CFLAGS";MP4FF_SUBDIR="mp4ff";MP4FF_LIB="mp4ff/libmp4ff.la"],enable_aac=no)
+ AC_CHECK_LIB(faad,NeAACDecInit2,[MPD_LIBS="$MPD_LIBS $FAAD_LIBS";MPD_CFLAGS="$MPD_CFLAGS $FAAD_CFLAGS"],enable_aac=no)
fi
fi
if test x$enable_aac = xyes; then
- AC_MSG_CHECKING(that FAAD2 uses buffer and bufferlen)
+ AC_CHECK_LIB(mp4ff,mp4ff_open_read,[MPD_LIBS="$MPD_LIBS $FAAD_LIBS";MPD_CFLAGS="$MPD_CFLAGS $FAAD_CFLAGS"],enable_aac=no)
+ fi
+ if test x$enable_aac = xyes; then
+ AC_MSG_CHECKING(that FAAD2 uses buffer and bufferlen)
AC_COMPILE_IFELSE([
#include <faad.h>
@@ -470,21 +470,21 @@ if test x$enable_oggvorbis = xyes && test x$use_tremor != xyes; then
fi
if test x$use_tremor = xyes; then
- if test "x$tremor_libraries" != "x" ; then
- TREMOR_LIBS="-L$tremor_libraries"
- elif test "x$tremor_prefix" != "x" ; then
- TREMOR_LIBS="-L$tremor_prefix/lib"
- elif test "x$prefix" != "xNONE"; then
- TREMOR_LIBS="-L$libdir"
- fi
- TREMOR_LIBS="$TREMOR_LIBS -lvorbisidec"
- if test "x$tremor_includes" != "x" ; then
- TREMOR_CFLAGS="-I$tremor_includes"
- elif test "x$tremor_prefix" != "x" ; then
- TREMOR_CFLAGS="-I$tremor_prefix/include"
- elif test "x$prefix" != "xNONE"; then
- TREMOR_CFLAGS="-I$includedir"
- fi
+ if test "x$tremor_libraries" != "x" ; then
+ TREMOR_LIBS="-L$tremor_libraries"
+ elif test "x$tremor_prefix" != "x" ; then
+ TREMOR_LIBS="-L$tremor_prefix/lib"
+ elif test "x$prefix" != "xNONE"; then
+ TREMOR_LIBS="-L$libdir"
+ fi
+ TREMOR_LIBS="$TREMOR_LIBS -lvorbisidec"
+ if test "x$tremor_includes" != "x" ; then
+ TREMOR_CFLAGS="-I$tremor_includes"
+ elif test "x$tremor_prefix" != "x" ; then
+ TREMOR_CFLAGS="-I$tremor_prefix/include"
+ elif test "x$prefix" != "xNONE"; then
+ TREMOR_CFLAGS="-I$includedir"
+ fi
ac_save_CFLAGS="$CFLAGS"
ac_save_LIBS="$LIBS"
CFLAGS="$CFLAGS $TREMOR_CFLAGS"
@@ -629,7 +629,7 @@ if test x$enable_mod = xyes; then
fi
fi
-AC_OUTPUT(src/mp4ff/Makefile doc/Makefile src/Makefile Makefile )
+AC_OUTPUT(doc/Makefile src/Makefile Makefile )
echo ""
echo "########### MPD CONFIGURATION ############"