aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2010-05-18 22:56:42 +0200
committerMax Kellermann <max@duempel.org>2010-05-20 09:33:05 +0200
commit9cce1d749a8ad8b3792881f16dbc4b1ddea49d1f (patch)
tree2cfe44b278a6f4d6d0093e99186036dddba7fa07 /configure.ac
parented0b48040c41d2080e4abaa311a158d7115ef842 (diff)
downloadmpd-9cce1d749a8ad8b3792881f16dbc4b1ddea49d1f.tar.gz
mpd-9cce1d749a8ad8b3792881f16dbc4b1ddea49d1f.tar.xz
mpd-9cce1d749a8ad8b3792881f16dbc4b1ddea49d1f.zip
output/win32: new output plugin for Windows Wave
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac18
1 files changed, 18 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index b5573dc81..88017360c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1372,6 +1372,22 @@ esac
AM_CONDITIONAL(ENABLE_SOLARIS_OUTPUT, test x$enable_solaris_output = xyes)
+dnl --------------------------------- Solaris ---------------------------------
+
+case "$host_os" in
+ mingw32* | windows*)
+ AC_DEFINE(ENABLE_WIN32_OUTPUT, 1, [Define to enable WIN32 wave support])
+ enable_win32_output=yes
+ MPD_LIBS="$MPD_LIBS -lwinmm"
+ ;;
+
+ *)
+ enable_win32_output=no
+ ;;
+esac
+
+AM_CONDITIONAL(ENABLE_WIN32_OUTPUT, test x$enable_win32_output = xyes)
+
dnl --------------------- Post Audio Output Plugins Tests ---------------------
if
test x$enable_alsa = xno &&
@@ -1388,6 +1404,7 @@ if
test x$enable_recorder_output = xno &&
test x$enable_shout = xno &&
test x$enable_solaris_output = xno &&
+ test x$enable_win32_output = xno &&
AC_MSG_ERROR([No Audio Output types configured!])
fi
@@ -1523,6 +1540,7 @@ results(mvp, [Media MVP])
results(shout, [SHOUTcast])
echo -ne '\n\t'
results(solaris, [Solaris])
+results(win32_output, [WIN32 wave])
if
test x$enable_shout = xyes ||