aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2010-12-21 22:23:01 +0100
committerMax Kellermann <max@duempel.org>2010-12-22 09:44:02 +0100
commit9bf7fde49f0883356a4fded05b3fe72db8d3686a (patch)
tree86ac3eae7ebdf1b818e40effcc7e84c51d8eab6c /configure.ac
parent4783ebc918a2e09c99f7a74645937df2618574ab (diff)
downloadmpd-9bf7fde49f0883356a4fded05b3fe72db8d3686a.tar.gz
mpd-9bf7fde49f0883356a4fded05b3fe72db8d3686a.tar.xz
mpd-9bf7fde49f0883356a4fded05b3fe72db8d3686a.zip
configure.ac: hook the cdio_paranoia input plugin
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 16 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index d8b2c5834..4d578c9f0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -135,6 +135,11 @@ AC_ARG_ENABLE(bzip2,
[enable bzip2 archive support (default: disabled)]),,
enable_bzip2=no)
+AC_ARG_ENABLE(cdio-paranoia,
+ AS_HELP_STRING([--enable-cdio-paranoia],
+ [enable support for audio CD support]),,
+ enable_cdio_paranoia=auto)
+
AC_ARG_ENABLE(cue,
AS_HELP_STRING([--enable-cue],
[enable support for libcue support]),,
@@ -633,6 +638,16 @@ if test x$enable_lastfm = xyes; then
fi
AM_CONDITIONAL(ENABLE_LASTFM, test x$enable_lastfm = xyes)
+dnl ---------------------------------- libcue ---------------------------------
+MPD_AUTO_PKG(cdio_paranoia, CDIO_PARANOIA, [libcdio_paranoia],
+ [libcdio_paranoia audio CD library], [libcdio_paranoia not found])
+if test x$enable_cdio_paranoia = xyes; then
+ AC_DEFINE([ENABLE_CDIO_PARANOIA], 1,
+ [Define to enable libcdio_paranoia support])
+fi
+
+AM_CONDITIONAL(ENABLE_CDIO_PARANOIA, test x$enable_cdio_paranoia = xyes)
+
dnl ---------------------------------- libogg ---------------------------------
if test x$with_tremor == xno || test -z $with_tremor; then
PKG_CHECK_MODULES(OGG, [ogg], enable_ogg=yes, enable_ogg=no)
@@ -1579,6 +1594,7 @@ echo -en '\nStreaming support:\n\t'
results(curl,[CURL])
results(lastfm,[Last.FM])
results(mms,[MMS])
+results(cdio_paranoia, [CDIO_PARANOIA])
echo -ne '\n\n##########################################\n\n'