aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2008-11-20 08:59:55 +0100
committerMax Kellermann <max@duempel.org>2008-11-20 08:59:55 +0100
commit90bfe65e54f45351219f48581a927ec52c6a9dd1 (patch)
treed466aa68951eeb3307e15bb0643567ee9c6dfac7 /configure.ac
parenta3d0e571cc839f861ec514b6b9cd1d8af2c1efa4 (diff)
downloadmpd-90bfe65e54f45351219f48581a927ec52c6a9dd1.tar.gz
mpd-90bfe65e54f45351219f48581a927ec52c6a9dd1.tar.xz
mpd-90bfe65e54f45351219f48581a927ec52c6a9dd1.zip
doc: process protocol.xml with xmlto
Generate and install protocol.html if xmlto is available.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 16 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 944c1c153..4d0788273 100644
--- a/configure.ac
+++ b/configure.ac
@@ -853,6 +853,22 @@ AM_CONDITIONAL(HAVE_ZEROCONF, test x$with_zeroconf != xno)
dnl
+dnl Documentation
+dnl
+
+AC_MSG_CHECKING([for xmlto (DocBook processing)])
+AC_PATH_PROG(XMLTO, xmlto)
+if test x$XMLTO != x; then
+ AC_SUBST(XMLTO)
+ AC_MSG_RESULT($XMLTO)
+else
+ AC_MSG_RESULT(no)
+fi
+
+AM_CONDITIONAL(HAVE_XMLTO, test x$XMLTO != x)
+
+
+dnl
dnl build options
dnl