aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2009-01-12 09:56:14 +0100
committerMax Kellermann <max@duempel.org>2009-01-12 09:56:14 +0100
commit9069a244a408a0e950a43caa9167f4aa610130bc (patch)
tree53c9a0917d612ffd2b86faa9cbc66b2684b234ec /configure.ac
parent52cf7953ffec271754baa22654981ae87bef5068 (diff)
downloadmpd-9069a244a408a0e950a43caa9167f4aa610130bc.tar.gz
mpd-9069a244a408a0e950a43caa9167f4aa610130bc.tar.xz
mpd-9069a244a408a0e950a43caa9167f4aa610130bc.zip
configure.ac: added the --enable-sqlite option
MPD will (optionall) use sqlite databases in the future. Add a configure option to enable that. There is no code yet to really use sqlite, so the practical use of this patch is limited.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 14 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index ff5de68e8..1380dde4b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -215,6 +215,20 @@ AM_CONDITIONAL(HAVE_ZEROCONF, test x$with_zeroconf != xno)
AM_CONDITIONAL(HAVE_AVAHI, test x$with_zeroconf = xavahi)
AM_CONDITIONAL(HAVE_BONJOUR, test x$with_zeroconf = xbonjour)
+AC_ARG_ENABLE(sqlite,
+ AS_HELP_STRING([--enable-sqlite],
+ [enable support for the SQLite database (default: disable)]),
+ [enable_sqlite=$enableval],
+ [enable_sqlite=no])
+
+if test x$enable_sqlite = xyes; then
+ PKG_CHECK_MODULES([SQLITE], [sqlite3],,
+ [AC_MSG_ERROR(sqlite not found)])
+ AC_DEFINE([ENABLE_SQLITE], 1, [Define to enable sqlite database support])
+fi
+
+AM_CONDITIONAL(ENABLE_SQLITE, test x$enable_sqlite = xyes)
+
dnl
dnl input plugins