aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2014-09-26 09:00:58 +0200
committerMax Kellermann <max@duempel.org>2014-09-26 09:29:18 +0200
commit8bf46a665e4b4bd9d663351fbfb8ff47b59dfdd6 (patch)
treed0895464e3ffb420f0b0ab358023a38b1727a801 /configure.ac
parentc4fca2aa614741f3d5bfef4eff039ae52c1a0a15 (diff)
downloadmpd-8bf46a665e4b4bd9d663351fbfb8ff47b59dfdd6.tar.gz
mpd-8bf46a665e4b4bd9d663351fbfb8ff47b59dfdd6.tar.xz
mpd-8bf46a665e4b4bd9d663351fbfb8ff47b59dfdd6.zip
configure.ac: add option to disable the DSD decoders
Allow building a smaller MPD binary for people who don't need DSD.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 13 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 9c8d72e1f..53cbc303a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -214,6 +214,11 @@ AC_ARG_ENABLE(documentation,
[build documentation (default: disable)]),,
[enable_documentation=no])
+AC_ARG_ENABLE(dsd,
+ AS_HELP_STRING([--enable-dsd],
+ [enable DSD decoder (default: enable)]),,
+ [enable_dsd=yes])
+
AC_ARG_ENABLE(ffmpeg,
AS_HELP_STRING([--enable-ffmpeg],
[enable FFMPEG support]),,
@@ -846,6 +851,14 @@ if test x$enable_audiofile = xyes; then
AC_DEFINE(HAVE_AUDIOFILE, 1, [Define for audiofile support])
fi
+dnl ----------------------------------- DSD -----------------------------------
+
+if test x$enable_dsd = xyes; then
+ AC_DEFINE(HAVE_DSD, 1, [Define for the DSD decoder])
+fi
+
+AM_CONDITIONAL(ENABLE_DSD, test x$enable_dsd = xyes)
+
dnl ----------------------------------- FAAD ----------------------------------
AM_PATH_FAAD()