aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2015-01-05 20:24:59 +0100
committerMax Kellermann <max@duempel.org>2015-01-06 19:38:55 +0100
commit8b217d531305433df01c789dab4dc81d58f05eba (patch)
treee81465cd429cfeaf12d49a4e128a8bcc703a4e9d /configure.ac
parentac62586badd439dfcc43df6a895f2988eb784e6d (diff)
downloadmpd-8b217d531305433df01c789dab4dc81d58f05eba.tar.gz
mpd-8b217d531305433df01c789dab4dc81d58f05eba.tar.xz
mpd-8b217d531305433df01c789dab4dc81d58f05eba.zip
fs/io/FileOutputStream: use O_TMPFILE if available
The Linux feature allows writing new files to an invisible file, and then replace the old file. This preserves the old file if we get interrupted by some event.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 79a4952b0..94ce62e73 100644
--- a/configure.ac
+++ b/configure.ac
@@ -219,7 +219,7 @@ AC_SEARCH_LIBS([socket], [socket])
AC_SEARCH_LIBS([gethostbyname], [nsl])
if test x$host_is_linux = xyes; then
- AC_CHECK_FUNCS(pipe2 accept4)
+ AC_CHECK_FUNCS(pipe2 accept4 linkat)
fi
AC_CHECK_FUNCS(getpwnam_r getpwuid_r)