aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorAvuton Olrich <avuton@gmail.com>2010-04-17 03:52:37 -0700
committerAvuton Olrich <avuton@gmail.com>2010-04-21 07:34:55 -0700
commit8b0fb1cc4db6ed8ef8faeccbe39fd065a0da3788 (patch)
treeed2a599e9304ecce28150d6320dc5780e4e5c49a /configure.ac
parente3d62305f1ea259c749bbd8dd950c191a68890d7 (diff)
downloadmpd-8b0fb1cc4db6ed8ef8faeccbe39fd065a0da3788.tar.gz
mpd-8b0fb1cc4db6ed8ef8faeccbe39fd065a0da3788.tar.xz
mpd-8b0fb1cc4db6ed8ef8faeccbe39fd065a0da3788.zip
configure.ac: Move OggVorbis to Decoder Plugins, add header.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 10 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index 3534f7698..871d1958b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1143,14 +1143,8 @@ if test x$use_tremor = xyes; then
if test x$enable_vorbis = xyes; then
AC_DEFINE(ENABLE_VORBIS_DECODER, 1, [Define for Ogg Vorbis support])
fi
-elif test x$enable_vorbis = xyes; then
- PKG_CHECK_MODULES(VORBIS, [ogg vorbis vorbisfile],
- AC_DEFINE(ENABLE_VORBIS_DECODER, 1, [Define for Ogg Vorbis support]),
- enable_vorbis=no)
fi
-AM_CONDITIONAL(ENABLE_VORBIS_DECODER, test x$enable_vorbis = xyes)
-
if test x$use_tremor = xyes; then
AC_DEFINE(HAVE_TREMOR,1,
[Define to use tremor (libvorbisidec) for ogg support])
@@ -1181,6 +1175,16 @@ AM_CONDITIONAL(HAVE_OGGFLAC, test x$enable_oggflac = xyes)
AM_CONDITIONAL(HAVE_FLAC_COMMON,
test x$enable_flac = xyes || test x$enable_oggflac = xyes)
+
+dnl -------------------------------- Ogg Vorbis -------------------------------
+if test x$enable_tremor != xyes -a test x$enable_vorbis = xyes; then
+ PKG_CHECK_MODULES(VORBIS, [ogg vorbis vorbisfile],
+ AC_DEFINE(ENABLE_VORBIS_DECODER, 1, [Define for Ogg Vorbis support]),
+ enable_vorbis=no)
+fi
+
+AM_CONDITIONAL(ENABLE_VORBIS_DECODER, test x$enable_vorbis = xyes)
+
AM_CONDITIONAL(HAVE_OGG_COMMON,
test x$enable_vorbis = xyes || test x$enable_oggflac = xyes || test x$enable_flac = xyes)