aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorWarren Dukes <warren.dukes@gmail.com>2005-03-13 19:23:09 +0000
committerWarren Dukes <warren.dukes@gmail.com>2005-03-13 19:23:09 +0000
commit8936789631ce729e44fc8fc0296d4b7c0cf0c5f6 (patch)
tree98d8b0624efdfed314692b080368519dc14891fb /configure.ac
parent3d81a723c7b501f9b2333fd73ee012645547d01e (diff)
downloadmpd-8936789631ce729e44fc8fc0296d4b7c0cf0c5f6.tar.gz
mpd-8936789631ce729e44fc8fc0296d4b7c0cf0c5f6.tar.xz
mpd-8936789631ce729e44fc8fc0296d4b7c0cf0c5f6.zip
add OS X configure stuff and added a skeleton audioOutput plugin for OS X
git-svn-id: https://svn.musicpd.org/mpd/trunk@3074 09075e82-0dd4-0310-85a5-a0d7c8717e4f
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 13 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index b2ddda6b0..a21304503 100644
--- a/configure.ac
+++ b/configure.ac
@@ -102,6 +102,13 @@ AP_maGiC_VALUE
)
fi
+enable_osx=no
+case $host in
+ *-darwin*)
+ AC_DEFINE(HAVE_OSX, 1, [Define for compiling OS X support])
+ enable_osx=yes ;;
+esac
+
if test x$enable_ogg = xno; then
AC_MSG_WARN("disabling shout streaming support since vorbis was not found")
fi
@@ -582,6 +589,12 @@ else
echo "Playing audio via ALSA ........disabled"
fi
+if test x$enable_osx = xyes; then
+ echo "Playing audio on OS X .........enabled"
+else
+ echo "Playing audio on OS X .........disabled"
+fi
+
if test x$enable_shout = xyes; then
echo "Streaming through shout .......enabled"
else