aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorAvuton Olrich <avuton@gmail.com>2011-12-10 17:40:20 -0800
committerMax Kellermann <max@duempel.org>2011-12-12 10:02:15 +0100
commit8459f27312bcbfc6bcd251d592e32b894a6e9950 (patch)
tree57a3c38d372bf0a1d39204f2298e1b29cc436c37 /configure.ac
parent7dfbdef505e7d58880acb3fa87848d7bd85ccf14 (diff)
downloadmpd-8459f27312bcbfc6bcd251d592e32b894a6e9950.tar.gz
mpd-8459f27312bcbfc6bcd251d592e32b894a6e9950.tar.xz
mpd-8459f27312bcbfc6bcd251d592e32b894a6e9950.zip
configure.ac: AC_HAVE_LIBRARY has been depreciated, move to AC_CHECK_LIB
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 4 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index 34273212e..eda125eab 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1000,19 +1000,18 @@ MPD_AUTO_PRE(sidplay, [sidplay decoder plugin], [No C++ compiler found])
if test x$enable_sidplay != xno; then
# we're not using pkg-config here
# because libsidplay2's .pc file requires libtool
- AC_HAVE_LIBRARY(sidplay2, [found_sidplay=yes], [found_sidplay=no])
+ AC_CHECK_LIB([sidplay2],[main],[found_sidplay=yes],[found_sidplay=no],[])
+
MPD_AUTO_PRE(sidplay, [sidplay decoder plugin],
[libsidplay2 not found])
fi
if test x$enable_sidplay != xno; then
- # can't use AC_HAVE_LIBRARY here, because the dash in the
- # library name triggers an autoconf bug
- AC_CHECK_LIB(resid-builder, main,
+ AC_CHECK_LIB([resid-builder], [main],
[found_sidplay=yes], [found_sidplay=no])
if test x$found_sidplay = xyes; then
- AC_HAVE_LIBRARY(sidutils,, [found_sidplay=no])
+ AC_CHECK_LIB([sidutils],[main],[],[found_sidplay=no],[])
fi
MPD_AUTO_RESULT(sidplay, [sidplay decoder plugin],