aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMiklos Vajna <vmiklos@frugalware.org>2011-09-30 08:37:36 +0200
committerMax Kellermann <max@duempel.org>2011-09-30 08:37:36 +0200
commit83f6498aac5f3d62611d392c8a35f1b1fcf1e75a (patch)
treedfbd9d5669e2df93e06eaf9c3c191bc717ec7e93 /configure.ac
parent525a791987c66ed2f8b1ca9e5357836f536fdb8b (diff)
downloadmpd-83f6498aac5f3d62611d392c8a35f1b1fcf1e75a.tar.gz
mpd-83f6498aac5f3d62611d392c8a35f1b1fcf1e75a.tar.xz
mpd-83f6498aac5f3d62611d392c8a35f1b1fcf1e75a.zip
Install systemd service file if systemd is available
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 020f15d35..1c1a4b91f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -33,6 +33,13 @@ fi
AC_PROG_INSTALL
AC_PROG_MAKE_SET
PKG_PROG_PKG_CONFIG
+AC_ARG_WITH([systemdsystemunitdir],
+ AS_HELP_STRING([--with-systemdsystemunitdir=DIR], [Directory for systemd service files]),
+ [], [with_systemdsystemunitdir=$($PKG_CONFIG --variable=systemdsystemunitdir systemd)])
+if test "x$with_systemdsystemunitdir" != xno; then
+ AC_SUBST([systemdsystemunitdir], [$with_systemdsystemunitdir])
+fi
+AM_CONDITIONAL(HAVE_SYSTEMD, [test -n "$with_systemdsystemunitdir" -a "x$with_systemdsystemunitdir" != xno ])
dnl ---------------------------------------------------------------------------
dnl Declare Variables
@@ -1592,5 +1599,6 @@ dnl ---------------------------------------------------------------------------
dnl Generate files
dnl ---------------------------------------------------------------------------
AC_OUTPUT(Makefile)
+AC_OUTPUT(mpd.service)
echo 'MPD is ready for compilation, type "make" to begin.'