aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2014-02-18 18:39:19 +0100
committerMax Kellermann <max@duempel.org>2014-02-18 18:39:19 +0100
commit7fee85c80ab5e0bf16f26e353a32026144dae6a4 (patch)
tree5cf5b2ef6e80475b1ef9514c3070630fc7e85395 /configure.ac
parent5d87a274a5cc30741d9e483fa189cbeb3c6087ba (diff)
downloadmpd-7fee85c80ab5e0bf16f26e353a32026144dae6a4.tar.gz
mpd-7fee85c80ab5e0bf16f26e353a32026144dae6a4.tar.xz
mpd-7fee85c80ab5e0bf16f26e353a32026144dae6a4.zip
configure.ac: fix linker failure when libvorbis/libogg are static
Link libvorbisfile first, followed to libvorbis and finally libogg. This order is necessary because libvorbisfile depends on libvorbis.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 471504527..81bdcea24 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1023,7 +1023,7 @@ if test x$enable_tremor = xyes; then
fi
fi
-MPD_AUTO_PKG(vorbis, VORBIS, [vorbis vorbisfile ogg],
+MPD_AUTO_PKG(vorbis, VORBIS, [vorbisfile vorbis ogg],
[Ogg Vorbis decoder], [libvorbis not found])
if test x$enable_vorbis = xyes; then
AC_DEFINE(ENABLE_VORBIS_DECODER, 1, [Define for Ogg Vorbis support])