aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorEric Wong <normalperson@yhbt.net>2006-07-22 23:28:26 +0000
committerEric Wong <normalperson@yhbt.net>2006-07-22 23:28:26 +0000
commit7f363eb9c18d2f35aab98db0c0cafbf059c67882 (patch)
tree6abb1d8ce00689cf81fe39b261569194bda3992b /configure.ac
parent0532c9ab4c3686adfaa7eaf8e8ec2217a2cfb59d (diff)
downloadmpd-7f363eb9c18d2f35aab98db0c0cafbf059c67882.tar.gz
mpd-7f363eb9c18d2f35aab98db0c0cafbf059c67882.tar.xz
mpd-7f363eb9c18d2f35aab98db0c0cafbf059c67882.zip
Cleanup some now unnecessary variables from the id3/mad removal
git-svn-id: https://svn.musicpd.org/mpd/trunk@4431 09075e82-0dd4-0310-85a5-a0d7c8717e4f
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 2 insertions, 10 deletions
diff --git a/configure.ac b/configure.ac
index 5d56f771f..7cbd40922 100644
--- a/configure.ac
+++ b/configure.ac
@@ -5,14 +5,6 @@ AC_PREREQ(2.58)
AC_INIT(mpd, 0.12.0, warren.dukes@gmail.com)
AM_INIT_AUTOMAKE($PACKAGE_NAME, $PACKAGE_VERSION)
-dnl MAD wants this stuff
-AC_SUBST(CCAS)
-AC_SUBST(CCASFLAGS)
-
-AC_SUBST(MAD_SUBDIR)
-AC_SUBST(MAD_LIB)
-AC_SUBST(ID3_SUBDIR)
-AC_SUBST(ID3_LIB)
AC_SUBST(MPD_LIBS)
AC_SUBST(MPD_CFLAGS)
@@ -259,7 +251,7 @@ if test x$enable_id3 = xyes; then
[use_libid3tag=no])
if test x$use_libid3tag = xyes; then
AC_CHECK_LIB(id3tag,id3_file_open,
- [ID3_LIB="$ID3TAG_LIBS";
+ [MPD_LIBS="$MPD_LIBS $ID3TAG_LIBS";
MPD_CFLAGS="$MPD_CFLAGS $ID3TAG_CFLAGS";
use_libid3tag=yes],
[use_libid3tag=no])
@@ -304,7 +296,7 @@ if test x$enable_mp3 = xyes; then
AC_CHECK_HEADERS(mad.h,use_libmad=yes,
[use_libmad=no])
if test x$use_libmad = xyes; then
- AC_CHECK_LIB(mad,mad_stream_init,[MAD_LIB="$MAD_LIBS";
+ AC_CHECK_LIB(mad,mad_stream_init,[MPD_LIBS="$MPD_LIBS $MAD_LIBS";
MPD_CFLAGS="$MPD_CFLAGS $MAD_CFLAGS";
use_libmad=yes],[use_libmad=no])
fi