aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorYuriy Kaminskiy <yumkam@mail.ru>2011-01-09 18:21:27 +0100
committerMax Kellermann <max@duempel.org>2011-01-09 18:21:27 +0100
commit77d71c4ee62485f74ac46cdced504db862b79750 (patch)
tree398476630eb9e5942379333f01948a44d5204a39 /configure.ac
parent8c0afd8557b1823e2df94c9f4de90c29eafbf035 (diff)
downloadmpd-77d71c4ee62485f74ac46cdced504db862b79750.tar.gz
mpd-77d71c4ee62485f74ac46cdced504db862b79750.tar.xz
mpd-77d71c4ee62485f74ac46cdced504db862b79750.zip
Makefile.am: resolve modplug vs. libsndfile cflags/headers conflict
A bit of automake magic (see info automake "Per-Object Flags"). Compile-tested.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 1 insertions, 14 deletions
diff --git a/configure.ac b/configure.ac
index a7e1612a5..c8a568ab4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -13,6 +13,7 @@ dnl Programs
dnl ---------------------------------------------------------------------------
AC_PROG_CC_C99
AC_PROG_CXX
+AC_PROG_RANLIB
HAVE_CXX=yes
if test x$CXX = xg++; then
@@ -849,15 +850,6 @@ if test x$enable_modplug = xyes; then
fi
AM_CONDITIONAL(HAVE_MODPLUG, test x$enable_modplug = xyes)
-dnl --------------------------- sndfile/modplug test --------------------------
-if test x$enable_sndfile = xauto && test x$enable_modplug = xyes; then
- dnl If modplug is enabled, enable sndfile only if explicitly
- dnl requested - modplug's modplug/sndfile.h is known to
- dnl conflict with libsndfile's sndfile.h.
- AC_MSG_NOTICE([disabling libsndfile auto-detection, because the modplug decoder is enabled])
- enable_sndfile=no
-fi
-
dnl -------------------------------- libsndfile -------------------------------
dnl See above test, which may disable this.
MPD_AUTO_PKG(sndfile, SNDFILE, [sndfile],
@@ -1582,11 +1574,6 @@ results(mms,[MMS])
printf '\n\n##########################################\n\n'
-if test x$enable_sndfile = xyes && test x$enable_modplug = xyes; then
- AC_MSG_WARN([compilation may fail, because libmodplug conflicts with libsndfile])
- AC_MSG_WARN([libmodplug ships modplug/sndfile.h, which hides libsndfile's sndfile.h])
-fi
-
echo 'Generating files needed for compilation'
dnl ---------------------------------------------------------------------------