aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2011-10-07 09:55:02 +0200
committerMax Kellermann <max@duempel.org>2011-10-07 09:56:38 +0200
commit72ff9bd3e67e1fb9acc7cc7857944d5b25d3e9c5 (patch)
tree0ae6ffeb7fcb7111fb204ff97dbaed570d7b5619 /configure.ac
parent039b3544902fe479fa2ce31f06de2c08377e0fc5 (diff)
downloadmpd-72ff9bd3e67e1fb9acc7cc7857944d5b25d3e9c5.tar.gz
mpd-72ff9bd3e67e1fb9acc7cc7857944d5b25d3e9c5.tar.xz
mpd-72ff9bd3e67e1fb9acc7cc7857944d5b25d3e9c5.zip
configure.ac: disable systemd service by default
Defaulting to "with systemd" causes problems for users who install MPD as an unprivileged user, and it breaks "make distcheck". It looks like enabling it by default creates too many practical problems for unexperienced users. With --with-systemdsystemunitdir (without a parameter), configure.ac attempts to auto-detect systemd.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 9 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 1c1a4b91f..9908e51fa 100644
--- a/configure.ac
+++ b/configure.ac
@@ -35,7 +35,15 @@ AC_PROG_MAKE_SET
PKG_PROG_PKG_CONFIG
AC_ARG_WITH([systemdsystemunitdir],
AS_HELP_STRING([--with-systemdsystemunitdir=DIR], [Directory for systemd service files]),
- [], [with_systemdsystemunitdir=$($PKG_CONFIG --variable=systemdsystemunitdir systemd)])
+ [], [with_systemdsystemunitdir=no])
+if test "x$with_systemdsystemunitdir" = xyes; then
+ AC_MSG_CHECKING(for systemd)
+ with_systemdsystemunitdir=$($PKG_CONFIG --variable=systemdsystemunitdir systemd)
+ if test -z "$with_systemdsystemunitdir"; then
+ AC_MSG_ERROR([Failed to detect systemd])
+ fi
+ AC_MSG_RESULT([$with_systemdsystemunitdir])
+fi
if test "x$with_systemdsystemunitdir" != xno; then
AC_SUBST([systemdsystemunitdir], [$with_systemdsystemunitdir])
fi