aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2013-11-21 22:50:58 +0100
committerMax Kellermann <max@duempel.org>2013-11-21 22:50:58 +0100
commit727c6226597fb710239b14e7985d97ec6b53f0ee (patch)
tree35daf2f3f6603b209421f3881dff86e41842bdbd /configure.ac
parent74a778e65fb7dd665d45725b995755e872692334 (diff)
downloadmpd-727c6226597fb710239b14e7985d97ec6b53f0ee.tar.gz
mpd-727c6226597fb710239b14e7985d97ec6b53f0ee.tar.xz
mpd-727c6226597fb710239b14e7985d97ec6b53f0ee.zip
configure.ac: auto-detect fluidsynth by default
The option "--enable-fluidsynth" was documented to be "auto" by default, when it was really "no".
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 5 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 268cb7aa7..b62cb22eb 100644
--- a/configure.ac
+++ b/configure.ac
@@ -874,10 +874,12 @@ AM_CONDITIONAL(HAVE_FLAC, test x$enable_flac = xyes)
enable_flac_encoder=$enable_flac
dnl -------------------------------- FluidSynth -------------------------------
+
+MPD_AUTO_PKG(fluidsynth, FLUIDSYNTH, [fluidsynth >= 1.1],
+ [fluidsynth decoder], [fluidsynth not found])
+
if test x$enable_fluidsynth = xyes; then
- PKG_CHECK_MODULES(FLUIDSYNTH, [fluidsynth >= 1.1],
- AC_DEFINE(ENABLE_FLUIDSYNTH, 1, [Define for fluidsynth support]),
- enable_fluidsynth=no)
+ AC_DEFINE(ENABLE_FLUIDSYNTH, 1, [Define for fluidsynth support])
fi
AM_CONDITIONAL(ENABLE_FLUIDSYNTH, test x$enable_fluidsynth = xyes)