aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2011-07-03 15:42:22 +0200
committerMax Kellermann <max@duempel.org>2011-07-03 15:42:22 +0200
commit65772a74e08af4b29466b3d41d42ec75d7e58788 (patch)
treeb5b01653be855dbf9470fc7b5f1ab324c832541c /configure.ac
parentcca2c2f4ca42f1c6a15d16bd2e8384971dad811d (diff)
downloadmpd-65772a74e08af4b29466b3d41d42ec75d7e58788.tar.gz
mpd-65772a74e08af4b29466b3d41d42ec75d7e58788.tar.xz
mpd-65772a74e08af4b29466b3d41d42ec75d7e58788.zip
configure: correct avahi/bonjour state on result page
Was always displayed as "no", even if one was found.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 7 insertions, 7 deletions
diff --git a/configure.ac b/configure.ac
index 0618bd413..b362592cf 100644
--- a/configure.ac
+++ b/configure.ac
@@ -537,15 +537,16 @@ no|avahi|bonjour)
;;
esac
+enable_avahi=no
+enable_bounjour=no
if test x$with_zeroconf != xno; then
if test x$with_zeroconf = xavahi || test x$with_zeroconf = xauto; then
PKG_CHECK_MODULES([AVAHI], [avahi-client avahi-glib],
- [found_avahi=1;AC_DEFINE([HAVE_AVAHI], 1, [Define to enable Avahi Zeroconf support])]
- MPD_LIBS="$MPD_LIBS $AVAHI_LIBS" MPD_CFLAGS="$MPD_CFLAGS $AVAHI_CFLAGS",
- [found_avahi=0])
+ [enable_avahi=yes;AC_DEFINE([HAVE_AVAHI], 1, [Define to enable Avahi Zeroconf support])]
+ MPD_LIBS="$MPD_LIBS $AVAHI_LIBS" MPD_CFLAGS="$MPD_CFLAGS $AVAHI_CFLAGS")
fi
- if test x$found_avahi = x1; then
+ if test x$enable_avahi = xyes; then
with_zeroconf=avahi
elif test x$with_zeroconf = xavahi; then
AC_MSG_ERROR([Avahi support requested but not found])
@@ -553,13 +554,12 @@ if test x$with_zeroconf != xno; then
if test x$with_zeroconf = xbonjour || test x$with_zeroconf = xauto; then
AC_CHECK_HEADER(dns_sd.h,
- [found_bonjour=1;AC_DEFINE([HAVE_BONJOUR], 1, [Define to enable Bonjour Zeroconf support])],
- [found_bonjour=0])
+ [enable_bonjour=yes;AC_DEFINE([HAVE_BONJOUR], 1, [Define to enable Bonjour Zeroconf support])])
AC_CHECK_LIB(dns_sd, DNSServiceRegister,
MPD_LIBS="$MPD_LIBS -ldns_sd")
fi
- if test x$found_bonjour = x1; then
+ if test x$enable_bonjour = xyes; then
with_zeroconf=bonjour
elif test x$with_zeroconf = xbonjour; then
AC_MSG_ERROR([Bonjour support requested but not found])