aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2014-12-09 20:50:33 +0100
committerMax Kellermann <max@duempel.org>2014-12-09 21:19:09 +0100
commit5c6f538b8578e1f0a828b5008ccc3a6a936d2756 (patch)
treeef6dafcd6e5789b6f40b4f47e7641aed9356c699 /configure.ac
parent00aa83a498fdfe3c66327269cb1634f103e5c7be (diff)
downloadmpd-5c6f538b8578e1f0a828b5008ccc3a6a936d2756.tar.gz
mpd-5c6f538b8578e1f0a828b5008ccc3a6a936d2756.tar.xz
mpd-5c6f538b8578e1f0a828b5008ccc3a6a936d2756.zip
configure.ac: inherit existing TREMOR_CFLAGS and TREMOR_LIBS
Replaces the old options --with-tremor-libraries and --with-tremor-includes.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac34
1 files changed, 12 insertions, 22 deletions
diff --git a/configure.ac b/configure.ac
index 779acd6a2..15806a330 100644
--- a/configure.ac
+++ b/configure.ac
@@ -468,16 +468,6 @@ AC_ARG_WITH(zeroconf,
[enable zeroconf backend (default=auto)]),,
with_zeroconf="auto")
-AC_ARG_WITH(tremor-libraries,
- AS_HELP_STRING([--with-tremor-libraries=DIR],
- [directory where Tremor library is installed (optional)]),,
- tremor_libraries="")
-
-AC_ARG_WITH(tremor-includes,
- AS_HELP_STRING([--with-tremor-includes=DIR],
- [directory where Tremor header files are installed (optional)]),,
- tremor_includes="")
-
dnl ---------------------------------------------------------------------------
dnl Mandatory Libraries
dnl ---------------------------------------------------------------------------
@@ -1000,6 +990,10 @@ fi
AM_CONDITIONAL(HAVE_MPCDEC, test x$enable_mpc = xyes)
dnl -------------------------------- Ogg Tremor -------------------------------
+
+AC_ARG_VAR([TREMOR_CFLAGS], [C compiler flags for Tremor])
+AC_ARG_VAR([TREMOR_LIBS], [linker flags for Tremor])
+
if test x$with_tremor = xyes || test x$with_tremor = xno; then
enable_tremor="$with_tremor"
tremor_prefix=""
@@ -1009,17 +1003,16 @@ else
fi
if test x$enable_tremor = xyes; then
- if test "x$tremor_libraries" != "x" ; then
- TREMOR_LIBS="-L$tremor_libraries"
- elif test "x$tremor_prefix" != "x" ; then
- TREMOR_LIBS="-L$tremor_prefix/lib"
- fi
- TREMOR_LIBS="$TREMOR_LIBS -lvorbisidec"
- if test "x$tremor_includes" != "x" ; then
- TREMOR_CFLAGS="-I$tremor_includes"
- elif test "x$tremor_prefix" != "x" ; then
+ if test x$TREMOR_CFLAGS = x && test x$tremor_prefix != x; then
TREMOR_CFLAGS="-I$tremor_prefix/include"
fi
+ if test x$TREMOR_LIBS = x; then
+ TREMOR_LIBS="-lvorbisidec"
+
+ if test x$tremor_prefix != x; then
+ TREMOR_LIBS="-L$tremor_prefix/lib $TREMOR_LIBS"
+ fi
+ fi
MPD_WITH_LIBRARY([TREMOR],
[AC_CHECK_FUNC([ov_read],,
@@ -1033,9 +1026,6 @@ else
TREMOR_LIBS=
fi
-AC_SUBST(TREMOR_CFLAGS)
-AC_SUBST(TREMOR_LIBS)
-
dnl -------------------------------- Ogg Vorbis -------------------------------
if test x$enable_tremor = xyes; then