aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2011-01-28 12:21:03 +0100
committerMax Kellermann <max@duempel.org>2011-01-28 12:21:03 +0100
commit5735c9efc1e9980a61c9ab779f138ea0409801e4 (patch)
tree5bb9e113249624476a04bc0890dfffe3450ebad8 /configure.ac
parent44b4b509499f7d5068a313f3ce9391bc6092f791 (diff)
downloadmpd-5735c9efc1e9980a61c9ab779f138ea0409801e4.tar.gz
mpd-5735c9efc1e9980a61c9ab779f138ea0409801e4.tar.xz
mpd-5735c9efc1e9980a61c9ab779f138ea0409801e4.zip
configure.ac: fix tremor configure test
When the configure options were moved around for 0.16, the order was changed, and the Tremor check broke.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 8 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index a1e310575..4fafb1899 100644
--- a/configure.ac
+++ b/configure.ac
@@ -934,13 +934,19 @@ if test x$enable_tremor = xyes; then
ac_save_LIBS="$LIBS"
CFLAGS="$CFLAGS $TREMOR_CFLAGS"
LIBS="$LIBS $TREMOR_LIBS"
- AC_CHECK_LIB(vorbisidec,ov_read,enable_vorbis=yes,enable_vorbis=no;
+ AC_CHECK_LIB(vorbisidec,ov_read,,enable_tremor=no;
AC_MSG_WARN([vorbisidec lib needed for ogg support with tremor -- disabling ogg support]))
CFLAGS="$ac_save_CFLAGS"
LIBS="$ac_save_LIBS"
+fi
+if test x$enable_tremor = xyes; then
AC_DEFINE(HAVE_TREMOR,1,
[Define to use tremor (libvorbisidec) for ogg support])
+ AC_DEFINE(ENABLE_VORBIS_DECODER, 1, [Define for Ogg Vorbis support]),
+else
+ TREMOR_CFLAGS=
+ TREMOR_LIBS=
fi
AC_SUBST(TREMOR_CFLAGS)
@@ -980,7 +986,7 @@ if test x$enable_vorbis = xyes; then
fi
fi
-AM_CONDITIONAL(ENABLE_VORBIS_DECODER, test x$enable_vorbis = xyes)
+AM_CONDITIONAL(ENABLE_VORBIS_DECODER, test x$enable_vorbis = xyes || test x$enable_tremor = xyes)
dnl --------------------------------- sidplay ---------------------------------
found_sidplay=$HAVE_CXX