aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2013-12-29 00:36:57 +0100
committerMax Kellermann <max@duempel.org>2013-12-29 01:25:27 +0100
commit5465647c2e2ac71b932f1268a83a00b36fdada82 (patch)
tree5328b6079df2b185c7570610a3d7e87b7b2b9747 /configure.ac
parenta2baeed3290691ced08cf9668b00865fb757698a (diff)
downloadmpd-5465647c2e2ac71b932f1268a83a00b36fdada82.tar.gz
mpd-5465647c2e2ac71b932f1268a83a00b36fdada82.tar.xz
mpd-5465647c2e2ac71b932f1268a83a00b36fdada82.zip
input/smbclient: new input plugin
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 14 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index a516e3b0c..ac60e72c8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -300,6 +300,11 @@ AC_ARG_ENABLE(curl,
[enable support for libcurl HTTP streaming (default: auto)]),,
[enable_curl=auto])
+AC_ARG_ENABLE(smbclient,
+ AS_HELP_STRING([--enable-smbclient],
+ [enable support for libsmbclient (default: auto)]),,
+ [enable_smbclient=auto])
+
AC_ARG_ENABLE(debug,
AS_HELP_STRING([--enable-debug],
[enable debugging (default: disabled)]),,
@@ -827,6 +832,14 @@ if test x$enable_curl = xyes; then
fi
AM_CONDITIONAL(ENABLE_CURL, test x$enable_curl = xyes)
+dnl ----------------------------------- smbclient -----------------------------
+MPD_AUTO_PKG(smbclient, SMBCLIENT, [smbclient >= 0.2],
+ [smbclient input plugin], [libsmbclient not found])
+if test x$enable_smbclient = xyes; then
+ AC_DEFINE(ENABLE_SMBCLIENT, 1, [Define when libsmbclient is used])
+fi
+AM_CONDITIONAL(ENABLE_SMBCLIENT, test x$enable_smbclient = xyes)
+
dnl --------------------------------- Despotify ---------------------------------
MPD_AUTO_PKG(despotify, DESPOTIFY, [despotify],
[Despotify support], [despotify not found])
@@ -1708,6 +1721,7 @@ fi
printf '\nStreaming support:\n\t'
results(cdio_paranoia, [CDIO_PARANOIA])
results(curl,[CURL])
+results(smbclient,[SMBCLIENT])
results(despotify,[Despotify])
results(soundcloud,[Soundcloud])
printf '\n\t'