aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2009-02-18 19:27:05 +0100
committerMax Kellermann <max@duempel.org>2009-02-18 19:27:05 +0100
commit54387d14516c15bcdf938cafe16c627570354587 (patch)
treec994e181bb0fa0049e60a9cd698fc6984d7c3cbc /configure.ac
parentfcf65de46bb8987c1237d7114d3b8e411b8f0d2a (diff)
downloadmpd-54387d14516c15bcdf938cafe16c627570354587.tar.gz
mpd-54387d14516c15bcdf938cafe16c627570354587.tar.xz
mpd-54387d14516c15bcdf938cafe16c627570354587.zip
configure.ac: added switch for test programs
The switch syntax is "--enable-test". There are no test programs yet.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 3b60f4b51..fbeb1beb8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1123,6 +1123,13 @@ if test "x$ENABLE_GPROF" = xyes; then
MPD_CFLAGS="$MPD_CFLAGS -pg"
fi
+AC_ARG_ENABLE(test,
+ AS_HELP_STRING([--enable-test],
+ [Build the test programs (default: disabled)]),,
+ enable_test=no)
+
+AM_CONDITIONAL(ENABLE_TEST, test "x$enable_test" = xyes)
+
dnl
dnl CFLAGS