aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2013-12-14 21:42:51 +0100
committerMax Kellermann <max@duempel.org>2014-12-05 00:37:02 +0100
commit533699abe750086fb4f17ac61219eb91826096ec (patch)
tree2ead7abb0b1c3bc88bf7c17ef3fb4a2d3d057e18 /configure.ac
parent267ccc98d3a9e9da0544a5123fcd1040e00360e9 (diff)
downloadmpd-533699abe750086fb4f17ac61219eb91826096ec.tar.gz
mpd-533699abe750086fb4f17ac61219eb91826096ec.tar.xz
mpd-533699abe750086fb4f17ac61219eb91826096ec.zip
playlist/soundcloud: drop support for libyajl1
Require the version 2 which has a more sane API.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 1 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 75e6526c4..5f510d22e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -770,14 +770,11 @@ dnl --------------------------------- Soundcloud ------------------------------
MPD_AUTO([soundcloud], [soundcloud.com support], [libyajl not found],
[PKG_CHECK_MODULES([YAJL], [yajl >= 2.0],
[found_soundcloud=yes],
- AC_CHECK_LIB([yajl], [yajl_parse_complete],
- [found_soundcloud=yes YAJL_CFLAGS=-DHAVE_YAJL1 YAJL_LIBS=-lyajl],
- [found_soundcloud=no]))])
+ [found_soundcloud=no])])
if test x$enable_soundcloud = xyes; then
AC_DEFINE(ENABLE_SOUNDCLOUD, 1, [Define when soundcloud is enabled])
fi
AM_CONDITIONAL(ENABLE_SOUNDCLOUD, test x$enable_soundcloud = xyes)
-AC_SUBST(YAJL_LIBS)
dnl ---------------------------------- cdio ---------------------------------
MPD_ENABLE_AUTO_PKG(cdio_paranoia, CDIO_PARANOIA, [libcdio_paranoia],