aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2014-02-18 08:33:06 +0100
committerMax Kellermann <max@duempel.org>2014-02-22 01:39:08 +0100
commit4dcf0b8ae0569beaf615fc19df2147bfb1597046 (patch)
tree99f489ff101a68db49752b2a2898967c5dfca287 /configure.ac
parent9574d11dc80248753c7fee22f3621879067c285b (diff)
downloadmpd-4dcf0b8ae0569beaf615fc19df2147bfb1597046.tar.gz
mpd-4dcf0b8ae0569beaf615fc19df2147bfb1597046.tar.xz
mpd-4dcf0b8ae0569beaf615fc19df2147bfb1597046.zip
first Android release
Finally, MPD runs on Android. For some small value of "runs". Very much work left, too much to describe.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac21
1 files changed, 21 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index c0aa04c58..f05c17b2a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -153,6 +153,27 @@ if test -z "$prefix" || test "x$prefix" = xNONE; then
fi
dnl ---------------------------------------------------------------------------
+dnl Android
+dnl ---------------------------------------------------------------------------
+
+AC_ARG_WITH([android-sdk],
+ AS_HELP_STRING([--with-android-sdk=DIR],
+ [Directory for Android SDK]),
+ [], [with_android_sdk=no])
+
+if test x$host_is_android = xyes; then
+ if test x$with_android_sdk = xno; then
+ AC_MSG_ERROR([Android build requires option --with-android-sdk=DIR])
+ fi
+
+ if ! test -x $with_android_sdk/tools/android; then
+ AC_MSG_ERROR([Android SDK not found in $with_android_sdk])
+ fi
+fi
+
+AC_SUBST(ANDROID_SDK, [$with_android_sdk])
+
+dnl ---------------------------------------------------------------------------
dnl Language Checks
dnl ---------------------------------------------------------------------------