aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorAvuton Olrich <avuton@gmail.com>2010-04-17 03:42:57 -0700
committerAvuton Olrich <avuton@gmail.com>2010-04-21 07:11:49 -0700
commit4cfcdd5e0f736310b69d5e11e55efbc7bad8a0a2 (patch)
tree43784c85ee20955c59d70e351070bd199eee6bc6 /configure.ac
parent9d72a341094ad0a4e9a01c3cd8d55e2fb034591e (diff)
downloadmpd-4cfcdd5e0f736310b69d5e11e55efbc7bad8a0a2.tar.gz
mpd-4cfcdd5e0f736310b69d5e11e55efbc7bad8a0a2.tar.xz
mpd-4cfcdd5e0f736310b69d5e11e55efbc7bad8a0a2.zip
configure.ac: Move libsndfile to Decoder Plugins, add header.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index f399e6d5e..a9da3de9a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1060,6 +1060,14 @@ if test x$enable_sndfile = xauto && test x$enable_modplug = xyes; then
enable_sndfile=no
fi
+dnl -------------------------------- libsndfile -------------------------------
+MPD_AUTO_PKG(sndfile, SNDFILE, [sndfile],
+ [libsndfile decoder plugin], [libsndfile not found])
+
+if test x$enable_sndfile = xyes; then
+ AC_DEFINE(ENABLE_SNDFILE, 1, [Define to enable the sndfile decoder plugin])
+fi
+AM_CONDITIONAL(ENABLE_SNDFILE, test x$enable_sndfile = xyes)
if test x$enable_mpc = xyes; then
if test "x$mpcdec_libraries" != "x" ; then