aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJean-Francois Dockes <jf@dockes.org>2013-11-01 19:26:01 +0100
committerMax Kellermann <max@duempel.org>2014-01-09 20:56:00 +0100
commit406452f019f097bf52d8db529eabe8dd2d0e977a (patch)
treed70ce0b620cc97ed9d352f89063fa7cecffd6341 /configure.ac
parent12b139beafc191d02277e7ce97b4c59f7bb0c095 (diff)
downloadmpd-406452f019f097bf52d8db529eabe8dd2d0e977a.tar.gz
mpd-406452f019f097bf52d8db529eabe8dd2d0e977a.tar.xz
mpd-406452f019f097bf52d8db529eabe8dd2d0e977a.zip
UPnP database plugin
[mk: renamed source files, applied coding style, reduced bloat, using MPD's threading library, using MPD's error reporting and logging library and refactoring, fixed lots of bugs]
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac23
1 files changed, 23 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 0af602fe4..5e0e054a5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -234,6 +234,11 @@ AC_ARG_ENABLE(expat,
[enable the expat XML parser]),,
enable_expat=auto)
+AC_ARG_ENABLE(upnp,
+ AS_HELP_STRING([--enable-upnp],
+ [enable UPnP client support (default: auto)]),,
+ enable_upnp=auto)
+
AC_ARG_ENABLE(adplug,
AS_HELP_STRING([--enable-adplug],
[enable the AdPlug decoder plugin (default: auto)]),,
@@ -900,6 +905,24 @@ fi
AM_CONDITIONAL(ENABLE_BZIP2_TEST, test x$BZIP2 != xno)
+dnl ---------------------------------- libupnp ---------------------------------
+
+if test x$enable_expat = xno; then
+ if test x$enable_upnp = xauto; then
+ AC_MSG_WARN([expat disabled -- disabling UPnP])
+ enable_upnp=no
+ elif test x$enable_upnp = xyes; then
+ AC_MSG_ERROR([expat disabled -- required for UPnP])
+ fi
+fi
+
+MPD_AUTO_PKG(upnp, UPNP, [libupnp],
+ [UPnP client support], [libupnp not found])
+if test x$enable_upnp = xyes; then
+ AC_DEFINE(HAVE_LIBUPNP, 1, [Define when libupnp is used])
+fi
+AM_CONDITIONAL(HAVE_LIBUPNP, test x$enable_upnp = xyes)
+
dnl --------------------------------- libzzip ---------------------------------
MPD_AUTO_PKG(zzip, ZZIP, [zziplib >= 0.13],
[libzzip archive library], [libzzip not found])