aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2010-01-01 17:10:10 +0100
committerMax Kellermann <max@duempel.org>2010-01-01 17:10:10 +0100
commit3adfbfe36d84b7c2a510f348aa79d76d829dcdab (patch)
treee1d22e8d7d93217467b292758d248b0d77b6a54e /configure.ac
parent9d3865cb952e95cfe8ac94f27f567f8408ec5b50 (diff)
downloadmpd-3adfbfe36d84b7c2a510f348aa79d76d829dcdab.tar.gz
mpd-3adfbfe36d84b7c2a510f348aa79d76d829dcdab.tar.xz
mpd-3adfbfe36d84b7c2a510f348aa79d76d829dcdab.zip
configure.ac: expose variables OPENAL_CFLAGS and OPENAL_LIBS
Don't add these to the global MPD_CFLAGS and MPD_LIBS. This allows test programs to link without libopenal.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 3 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index c45574b0b..15fc7549d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -829,6 +829,9 @@ fi
AM_CONDITIONAL(HAVE_OSS, test x$enable_oss = xyes)
+AC_SUBST(OPENAL_CFLAGS,"")
+AC_SUBST(OPENAL_LIBS,"")
+
if test x$enable_openal = xyes; then
if test x$enable_osx = xyes; then
AC_CHECK_HEADERS([OpenAL/al.h OpenAL/alc.h], [], [enable_openal=no])
@@ -845,11 +848,6 @@ if test x$enable_openal = xyes; then
fi
fi
-if test x$enable_openal = xyes; then
- MPD_CFLAGS="$MPD_CFLAGS $OPENAL_CFLAGS"
- MPD_LIBS="$MPD_LIBS $OPENAL_LIBS"
-fi
-
AM_CONDITIONAL(HAVE_OPENAL, test x$enable_openal = xyes)
if test x$enable_fifo = xyes; then