aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2008-10-14 17:21:51 +0200
committerMax Kellermann <max@duempel.org>2008-10-14 17:21:51 +0200
commit37b69759da1f03ef6180aa8c919d74d1e31119fa (patch)
treee256639fed268a39d5c31316f79c43c8f4ebe431 /configure.ac
parent86782faa18b32941eb2e39dd552d58b934279f1a (diff)
downloadmpd-37b69759da1f03ef6180aa8c919d74d1e31119fa.tar.gz
mpd-37b69759da1f03ef6180aa8c919d74d1e31119fa.tar.xz
mpd-37b69759da1f03ef6180aa8c919d74d1e31119fa.zip
configure.ac: moved CFLAGS checks down
Some warning flags may cause errors during library detection code. Do the CFLAGS checks at the end.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac43
1 files changed, 30 insertions, 13 deletions
diff --git a/configure.ac b/configure.ac
index d1579fa95..0e72cda26 100644
--- a/configure.ac
+++ b/configure.ac
@@ -23,19 +23,6 @@ AC_DEFINE(PROTOCOL_VERSION, "0.14.0", [The mpd protocol version])
MPD_LIBS=""
MPD_CFLAGS=""
-if test x$GCC = xyes
-then
- MPD_CHECK_FLAG([-Wall])
- MPD_CHECK_FLAG([-Wextra])
- MPD_CHECK_FLAG([-Wno-deprecated-declarations])
- MPD_CHECK_FLAG([-Wmissing-prototypes])
- MPD_CHECK_FLAG([-Wdeclaration-after-statement])
- MPD_CHECK_FLAG([-Wshadow])
- MPD_CHECK_FLAG([-Wpointer-arith])
- MPD_CHECK_FLAG([-Wstrict-prototypes])
- MPD_CHECK_FLAG([-Wcast-qual])
- MPD_CHECK_FLAG([-Wwrite-strings])
-fi
if test -z "$prefix" || test "x$prefix" = xNONE; then
local_lib=
@@ -692,8 +679,38 @@ if test x$with_zeroconf != xno; then
fi
fi
+
+dnl
+dnl CFLAGS
+dnl
+
+if test x$GCC = xyes
+then
+ MPD_CHECK_FLAG([-Wall])
+ MPD_CHECK_FLAG([-Wextra])
+ MPD_CHECK_FLAG([-Wno-deprecated-declarations])
+ MPD_CHECK_FLAG([-Wmissing-prototypes])
+ MPD_CHECK_FLAG([-Wdeclaration-after-statement])
+ MPD_CHECK_FLAG([-Wshadow])
+ MPD_CHECK_FLAG([-Wpointer-arith])
+ MPD_CHECK_FLAG([-Wstrict-prototypes])
+ MPD_CHECK_FLAG([-Wcast-qual])
+ MPD_CHECK_FLAG([-Wwrite-strings])
+fi
+
+
+dnl
+dnl generate files
+dnl
+
+
AC_OUTPUT(src/mp4ff/Makefile doc/Makefile src/Makefile Makefile )
+
+dnl
+dnl pretty-print result
+dnl
+
echo ""
echo "########### MPD CONFIGURATION ############"
echo ""