aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2014-01-27 14:47:46 +0100
committerMax Kellermann <max@duempel.org>2014-01-27 15:00:44 +0100
commit36bab6ef066c6898a791dd15054301f80757b3f6 (patch)
tree71bcc45ecc70af50de606033d8765d3f1b8423af /configure.ac
parent5273900b0e20e75c07b8df098af96fa7f0c6d238 (diff)
downloadmpd-36bab6ef066c6898a791dd15054301f80757b3f6.tar.gz
mpd-36bab6ef066c6898a791dd15054301f80757b3f6.tar.xz
mpd-36bab6ef066c6898a791dd15054301f80757b3f6.zip
configure.ac: detect libsmbclient without pkg-config
The pkg-config file has been added in Samba 4.0. This commits adds a fallback for older libsmbclient versions.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 41f9845fb..0da4eb645 100644
--- a/configure.ac
+++ b/configure.ac
@@ -837,7 +837,8 @@ fi
AM_CONDITIONAL(ENABLE_CURL, test x$enable_curl = xyes)
dnl ----------------------------------- smbclient -----------------------------
-MPD_AUTO_PKG(smbclient, SMBCLIENT, [smbclient >= 0.2],
+MPD_AUTO_PKG_LIB(smbclient, SMBCLIENT, [smbclient >= 0.2],
+ [smbclient], [smbc_init], [-lsmbclient], [],
[smbclient input plugin], [libsmbclient not found])
if test x$enable_smbclient = xyes; then
AC_DEFINE(ENABLE_SMBCLIENT, 1, [Define when libsmbclient is used])