aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2014-10-25 00:14:25 +0200
committerMax Kellermann <max@duempel.org>2014-10-25 00:14:25 +0200
commit2e24adae896447a6b2bfca9994108dc5de85bfd3 (patch)
tree65a8e396232c4a6213d3bcf784587ba2746834ad /configure.ac
parent188b94cb3e2d6257ad5545160563a7c94a0bc291 (diff)
downloadmpd-2e24adae896447a6b2bfca9994108dc5de85bfd3.tar.gz
mpd-2e24adae896447a6b2bfca9994108dc5de85bfd3.tar.xz
mpd-2e24adae896447a6b2bfca9994108dc5de85bfd3.zip
configure.ac: require xmlto for --enable-documentation
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 4 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 107a5afa2..168a01fb3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1733,8 +1733,11 @@ dnl Documentation
dnl ---------------------------------------------------------------------------
if test x$enable_documentation = xyes; then
AC_PATH_PROG(XMLTO, xmlto)
+ if test x$XMLTO = x; then
+ AC_MSG_ERROR([xmlto not found])
+ fi
+
AC_SUBST(XMLTO)
- AM_CONDITIONAL(HAVE_XMLTO, test x$XMLTO != x)
AC_PATH_PROG(DOXYGEN, doxygen)
if test x$DOXYGEN = x; then
@@ -1742,8 +1745,6 @@ if test x$enable_documentation = xyes; then
fi
AC_SUBST(DOXYGEN)
-else
- AM_CONDITIONAL(HAVE_XMLTO, false)
fi
AM_CONDITIONAL(ENABLE_DOCUMENTATION, test x$enable_documentation = xyes)