aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2009-03-07 23:05:25 +0100
committerMax Kellermann <max@duempel.org>2009-03-07 23:05:25 +0100
commit2ba5278440bc105ee4509be9ab0c6a225b0c1fdd (patch)
tree7da7b5ffe0800e8a6eb4e84f3027c2f5f4874b42 /configure.ac
parentbd6bcfb6760ecd6b89175f578d89f15c809ac2a4 (diff)
downloadmpd-2ba5278440bc105ee4509be9ab0c6a225b0c1fdd.tar.gz
mpd-2ba5278440bc105ee4509be9ab0c6a225b0c1fdd.tar.xz
mpd-2ba5278440bc105ee4509be9ab0c6a225b0c1fdd.zip
configure.ac: fix --enable-bzip2 and --enable-iso9660 variable name
Another "remove redundant explicit $enableval assignments" breakage.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac28
1 files changed, 14 insertions, 14 deletions
diff --git a/configure.ac b/configure.ac
index 206241f15..ac5819f31 100644
--- a/configure.ac
+++ b/configure.ac
@@ -290,16 +290,16 @@ dnl bzip2
AC_ARG_ENABLE(bzip2,
AS_HELP_STRING([--enable-bzip2],
[enable bzip2 archive support (default: disabled)]),,
- enable_bz2=no)
+ enable_bzip2=no)
-if test x$enable_bz2 = xyes; then
+if test x$enable_bzip2 = xyes; then
AC_CHECK_LIB(bz2, BZ2_bzDecompressInit,
[MPD_LIBS="$MPD_LIBS -lbz2"],
- enable_bz2=no)
+ enable_bzip2=no)
fi
-AM_CONDITIONAL(HAVE_BZ2, test x$enable_bz2 = xyes)
-if test x$enable_bz2 = xyes; then
+AM_CONDITIONAL(HAVE_BZ2, test x$enable_bzip2 = xyes)
+if test x$enable_bzip2 = xyes; then
AC_DEFINE(HAVE_BZ2, 1, [Define to have bz2 archive support])
fi
@@ -324,24 +324,24 @@ dnl iso9660
AC_ARG_ENABLE(iso9660,
AS_HELP_STRING([--enable-iso9660],
[enable iso9660 archive support (default: disabled)]),,
- enable_iso=no)
+ enable_iso9660=no)
-if test x$enable_iso = xyes; then
+if test x$enable_iso9660 = xyes; then
AC_CHECK_LIB(iso9660, iso9660_ifs_readdir,
[MPD_LIBS="$MPD_LIBS -liso9660"],
- enable_iso=no)
+ enable_iso9660=no)
fi
-AM_CONDITIONAL(HAVE_ISO, test x$enable_iso = xyes)
-if test x$enable_iso = xyes; then
+AM_CONDITIONAL(HAVE_ISO, test x$enable_iso9660 = xyes)
+if test x$enable_iso9660 = xyes; then
AC_DEFINE(HAVE_ISO, 1, [Define to have iso archive support])
fi
dnl archive API
if
- test x$enable_bz2 = xyes ||
+ test x$enable_bzip2 = xyes ||
test x$enable_zip = xyes ||
- test x$enable_iso = xyes; then
+ test x$enable_iso9660 = xyes; then
enable_archive=yes
AC_DEFINE(ENABLE_ARCHIVE, 1, [The archive API is available])
else
@@ -1297,13 +1297,13 @@ fi
echo ""
echo " Archive support:"
-if test x$enable_bz2 = xyes; then
+if test x$enable_bzip2 = xyes; then
echo " BZ2 archives support ..........enabled"
else
echo " BZ2 archives support ..........disabled"
fi
-if test x$enable_iso = xyes; then
+if test x$enable_iso9660 = xyes; then
echo " ISO 9660 archives support .....enabled"
else
echo " ISO 9660 archives support .....disabled"