aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorRobert Vollmert <rvollmert-lists@gmx.net>2012-03-19 21:16:48 +0100
committerMax Kellermann <max@duempel.org>2012-03-19 21:16:48 +0100
commit281b8714efbf930a80eb3ab6056240ae0882aa22 (patch)
tree1d2c6168d55d1dd7afe3f0c899ef4ef22de4c2b6 /configure.ac
parentd5be3cce9cb3f198c7b36ac09400e963555066c8 (diff)
downloadmpd-281b8714efbf930a80eb3ab6056240ae0882aa22.tar.gz
mpd-281b8714efbf930a80eb3ab6056240ae0882aa22.tar.xz
mpd-281b8714efbf930a80eb3ab6056240ae0882aa22.zip
playlist/soundcloud: support libyajl2
[mk: backwars compatibility and autoconf check]
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 5 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index ba2b35f69..a84d6f698 100644
--- a/configure.ac
+++ b/configure.ac
@@ -709,9 +709,11 @@ AM_CONDITIONAL(ENABLE_DESPOTIFY, test x$enable_despotify = xyes)
dnl --------------------------------- Soundcloud ------------------------------
if test x$enable_soundcloud != xno; then
- AC_CHECK_LIB([yajl], [yajl_alloc],
- [found_soundcloud=yes YAJL_LIBS=-lyajl],
- [found_soundcloud=no])
+ PKG_CHECK_MODULES([YAJL], [yajl >= 2.0],
+ [found_soundcloud=yes],
+ AC_CHECK_LIB([yajl], [yajl_alloc],
+ [found_soundcloud=yes YAJL_CFLAGS=-DHAVE_YAJL1 YAJL_LIBS=-lyajl],
+ [found_soundcloud=no]))
fi
MPD_AUTO_RESULT([soundcloud], [soundcloud.com support], [libyajl not found])
if test x$enable_soundcloud = xyes; then