aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2011-09-19 07:39:27 +0200
committerMax Kellermann <max@duempel.org>2011-09-19 09:39:35 +0200
commit1d8840412fc1dd76a73ee13413cd7fc9a6ff229a (patch)
treec135c1fd1cbe931b99bf5e37db0860306e2ac187 /configure.ac
parentdf1152ee0f3b3761e9956c0084094400d1250705 (diff)
downloadmpd-1d8840412fc1dd76a73ee13413cd7fc9a6ff229a.tar.gz
mpd-1d8840412fc1dd76a73ee13413cd7fc9a6ff229a.tar.xz
mpd-1d8840412fc1dd76a73ee13413cd7fc9a6ff229a.zip
configure.ac: add option --enable-solaris-output
Allow enabling the plugin explicitly without running Solaris, to test the build.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac17
1 files changed, 14 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index e87cf114b..50e8d8c7a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -324,6 +324,11 @@ AC_ARG_ENABLE(sndfile,
[enable sndfile support]),,
enable_sndfile=auto)
+AC_ARG_ENABLE(solaris_output,
+ AS_HELP_STRING([--enable-solaris-output],
+ [enables the Solaris /dev/audio output]),,
+ [enable_solaris_output=auto])
+
AC_ARG_ENABLE(sqlite,
AS_HELP_STRING([--enable-sqlite],
[enable support for the SQLite database]),,
@@ -1370,16 +1375,22 @@ fi
AM_CONDITIONAL(HAVE_SHOUT, test x$enable_shout = xyes)
dnl --------------------------------- Solaris ---------------------------------
-case "$host_os" in
+
+if test x$enable_solaris_output = xauto; then
+ case "$host_os" in
solaris*)
- AC_DEFINE(ENABLE_SOLARIS_OUTPUT, 1, [Define to enable Solaris /dev/audio support])
enable_solaris_output=yes
;;
*)
enable_solaris_output=no
;;
-esac
+ esac
+fi
+
+if test x$enable_solaris_output = xyes; then
+ AC_DEFINE(ENABLE_SOLARIS_OUTPUT, 1, [Define to enable Solaris /dev/audio support])
+fi
AM_CONDITIONAL(ENABLE_SOLARIS_OUTPUT, test x$enable_solaris_output = xyes)