aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2014-12-09 20:23:22 +0100
committerMax Kellermann <max@duempel.org>2014-12-09 21:19:09 +0100
commit184557bfed39a84685ea3398f4c5610d2cb4f5bf (patch)
tree7551a18a3290a7d5914e5dba5a718bcd5d45e0da /configure.ac
parentb4253210d2dcbd57873a7785f7aa55155ad3f125 (diff)
downloadmpd-184557bfed39a84685ea3398f4c5610d2cb4f5bf.tar.gz
mpd-184557bfed39a84685ea3398f4c5610d2cb4f5bf.tar.xz
mpd-184557bfed39a84685ea3398f4c5610d2cb4f5bf.zip
m4/mpd_with_flags: add macro MPD_WITH_FLAGS
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 4 insertions, 8 deletions
diff --git a/configure.ac b/configure.ac
index 4ff334c8f..1f8f4f75d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1019,14 +1019,10 @@ if test x$enable_tremor = xyes; then
elif test "x$tremor_prefix" != "x" ; then
TREMOR_CFLAGS="-I$tremor_prefix/include"
fi
- ac_save_CFLAGS="$CFLAGS"
- ac_save_LIBS="$LIBS"
- CFLAGS="$CFLAGS $TREMOR_CFLAGS"
- LIBS="$LIBS $TREMOR_LIBS"
- AC_CHECK_LIB(vorbisidec,ov_read,,enable_tremor=no;
- AC_MSG_WARN([vorbisidec lib needed for ogg support with tremor -- disabling ogg support]))
- CFLAGS="$ac_save_CFLAGS"
- LIBS="$ac_save_LIBS"
+
+ MPD_WITH_LIBRARY([TREMOR],
+ [AC_CHECK_LIB(vorbisidec,ov_read,,enable_tremor=no;
+ AC_MSG_WARN([vorbisidec lib needed for ogg support with tremor -- disabling ogg support]))])
fi
if test x$enable_tremor = xyes; then