aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2008-12-27 14:33:41 +0100
committerMax Kellermann <max@duempel.org>2008-12-27 14:33:41 +0100
commit0fe0425dee555027c94a39ca0bca5bac947f4702 (patch)
treeb56c3d787c766cda67b29dcd7664dbd516835373 /configure.ac
parent4c13a276c4340752fe955057cbb8cae82163292d (diff)
downloadmpd-0fe0425dee555027c94a39ca0bca5bac947f4702.tar.gz
mpd-0fe0425dee555027c94a39ca0bca5bac947f4702.tar.xz
mpd-0fe0425dee555027c94a39ca0bca5bac947f4702.zip
disable archive API without plugins
When there are no archive plugins, we do not need the archive API at all. Drop all its overhead.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 9bfccafaf..16189a07a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -217,6 +217,16 @@ if test x$enable_iso = xyes; then
AC_DEFINE(HAVE_ISO, 1, [Define to have iso archive support])
fi
+dnl archive API
+if test x$enable_bz2 = xyes || test x$enable_zip = xyes || test x$enable_iso = xyes; then
+ enable_archive=yes
+ AC_DEFINE(ENABLE_ARCHIVE, 1, [The archive API is available])
+else
+ enable_archive=no
+fi
+
+AM_CONDITIONAL(ENABLE_ARCHIVE, test x$enable_archive = xyes)
+
dnl
dnl decoder plugins