aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorPHO <pho@cielonegro.org>2015-01-26 13:02:15 +0900
committerMax Kellermann <max@duempel.org>2015-01-26 20:39:49 +0100
commit023b9c1e7e6792de4da0b867b6bb5d425928bd5b (patch)
tree5f6b62d9ac30a7262763ca654a1017ba6233a19a /configure.ac
parent4c616626440beaedd125a788faecf06a3ebe85af (diff)
downloadmpd-023b9c1e7e6792de4da0b867b6bb5d425928bd5b.tar.gz
mpd-023b9c1e7e6792de4da0b867b6bb5d425928bd5b.tar.xz
mpd-023b9c1e7e6792de4da0b867b6bb5d425928bd5b.zip
Test the existence of strndup(3) before using it.
This can eliminate the ad-hoc "#ifdef WIN32" and can also support other platforms lacking it as well (including Darwin 9).
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index d36afffa4..199ff9896 100644
--- a/configure.ac
+++ b/configure.ac
@@ -206,6 +206,7 @@ if test x$host_is_linux = xyes; then
fi
AC_CHECK_FUNCS(getpwnam_r getpwuid_r)
+AC_CHECK_FUNCS(strndup)
if test x$host_is_linux = xyes; then
MPD_OPTIONAL_FUNC(eventfd, eventfd, USE_EVENTFD)