aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2014-12-29 22:25:14 +0100
committerMax Kellermann <max@duempel.org>2014-12-29 22:25:14 +0100
commitfe9db8b369cdb9e62396b6f92d48b03f4c5ad703 (patch)
tree4ca3fa1bf18575d9227e2bee4352cd4e63b7e14f /Makefile.am
parentca035d0e8dec5e6f370885a8e21ac3c7998d8523 (diff)
downloadmpd-fe9db8b369cdb9e62396b6f92d48b03f4c5ad703.tar.gz
mpd-fe9db8b369cdb9e62396b6f92d48b03f4c5ad703.tar.xz
mpd-fe9db8b369cdb9e62396b6f92d48b03f4c5ad703.zip
{mixer,output}/pulse: use a common Domain instance
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 8 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index e1c19bb13..5fe7b70ad 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1231,7 +1231,6 @@ OUTPUT_LIBS = \
$(ROAR_LIBS) \
$(JACK_LIBS) \
$(OPENAL_LIBS) \
- $(PULSE_LIBS) \
$(SHOUT_LIBS)
OUTPUT_API_SRC = \
@@ -1256,7 +1255,7 @@ liboutput_plugins_a_SOURCES = \
MIXER_LIBS = \
libmixer_plugins.a \
- $(PULSE_LIBS)
+ $(PULSE_LIBS2)
MIXER_API_SRC = \
src/mixer/Listener.hxx \
@@ -1349,6 +1348,13 @@ liboutput_plugins_a_SOURCES += \
src/output/plugins/PulseOutputPlugin.hxx
libmixer_plugins_a_SOURCES += \
src/mixer/plugins/PulseMixerPlugin.cxx src/mixer/plugins/PulseMixerPlugin.hxx
+
+noinst_LIBRARIES += libpulse.a
+libpulse_a_SOURCES = \
+ src/lib/pulse/Domain.cxx src/lib/pulse/Domain.hxx
+libpulse_a_CPPFLAGS = $(AM_CPPFLAGS) $(PULSE_CFLAGS)
+PULSE_LIBS2 = libpulse.a $(PULSE_LIBS)
+OUTPUT_LIBS += $(PULSE_LIBS2)
endif
if HAVE_SHOUT