aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2010-05-18 23:40:11 +0200
committerMax Kellermann <max@duempel.org>2010-05-19 11:47:55 +0200
commitfc5a7a877434017ac8361243a4153aa4f906ea22 (patch)
tree70efb58e38d3a4fbc2e589c8d64573a30c855c25 /Makefile.am
parent8248f498b280f278f85a5bd6fad59245858f66cb (diff)
downloadmpd-fc5a7a877434017ac8361243a4153aa4f906ea22.tar.gz
mpd-fc5a7a877434017ac8361243a4153aa4f906ea22.tar.xz
mpd-fc5a7a877434017ac8361243a4153aa4f906ea22.zip
Makefile.am: disable test/read_mixer unless HAVE_ALSA
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index d9f32f468..c07493f7b 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -797,11 +797,15 @@ noinst_PROGRAMS = \
test/read_tags \
test/run_filter \
test/run_output \
- test/read_mixer \
test/run_convert \
test/run_normalize \
test/software_volume
+if HAVE_ALSA
+# this debug program is still ALSA specific
+noinst_PROGRAMS += test/read_mixer
+endif
+
test_read_conf_CPPFLAGS = $(AM_CPPFLAGS) \
$(GLIB_CFLAGS)
test_read_conf_LDADD = $(MPD_LIBS) \