aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2014-01-27 09:51:31 +0100
committerMax Kellermann <max@duempel.org>2014-01-27 09:51:31 +0100
commitf7eb2b697ef6ac523632ad27b43b185f5901438c (patch)
treea1bccc129ad823994e5e8d2e015b57ce1c1fc907 /Makefile.am
parentda67260c955ebe1bc590b461e5ee8c9665f26f5b (diff)
downloadmpd-f7eb2b697ef6ac523632ad27b43b185f5901438c.tar.gz
mpd-f7eb2b697ef6ac523632ad27b43b185f5901438c.tar.xz
mpd-f7eb2b697ef6ac523632ad27b43b185f5901438c.zip
test/test_icy_parser: unit test for IcyMetaDataParser.cxx
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am11
1 files changed, 11 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 7240cb3f1..c7cf631bb 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1061,6 +1061,7 @@ C_TESTS = \
test/test_util \
test/test_byte_reverse \
test/test_mixramp \
+ test/test_icy_parser \
test/test_pcm \
test/test_queue_priority
@@ -1496,6 +1497,16 @@ test_test_mixramp_LDADD = \
$(GLIB_LIBS) \
$(CPPUNIT_LIBS)
+test_test_icy_parser_SOURCES = \
+ src/Log.cxx \
+ test/test_icy_parser.cxx
+test_test_icy_parser_CPPFLAGS = $(AM_CPPFLAGS) $(CPPUNIT_CFLAGS) -DCPPUNIT_HAVE_RTTI=0
+test_test_icy_parser_CXXFLAGS = $(AM_CXXFLAGS) -Wno-error=deprecated-declarations
+test_test_icy_parser_LDADD = \
+ libtag.a \
+ $(GLIB_LIBS) \
+ $(CPPUNIT_LIBS)
+
test_test_pcm_SOURCES = \
test/test_pcm_util.hxx \
test/test_pcm_dither.cxx \