aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2014-03-15 17:30:08 +0100
committerMax Kellermann <max@duempel.org>2014-03-15 18:35:52 +0100
commitf660d30138e07afe81e6cbcedb1aab2a4fc36b41 (patch)
tree2513679ef9aa61a5d4c4fb53ef41aae575427b44 /Makefile.am
parentb10276ff98ee11ebef112a5a04ee749c20902a97 (diff)
downloadmpd-f660d30138e07afe81e6cbcedb1aab2a4fc36b41.tar.gz
mpd-f660d30138e07afe81e6cbcedb1aab2a4fc36b41.tar.xz
mpd-f660d30138e07afe81e6cbcedb1aab2a4fc36b41.zip
util/CircularBuffer: new buffer class
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 700511338..42b4169ec 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -362,6 +362,7 @@ libutil_a_SOURCES = \
src/util/DynamicFifoBuffer.hxx \
src/util/ConstBuffer.hxx \
src/util/WritableBuffer.hxx \
+ src/util/CircularBuffer.hxx \
src/util/LazyRandomEngine.cxx src/util/LazyRandomEngine.hxx \
src/util/SliceBuffer.hxx \
src/util/HugeAllocator.cxx src/util/HugeAllocator.hxx \
@@ -1832,6 +1833,7 @@ test_run_inotify_LDADD = \
endif
test_test_util_SOURCES = \
+ test/TestCircularBuffer.hxx \
test/test_util.cxx
test_test_util_CPPFLAGS = $(AM_CPPFLAGS) $(CPPUNIT_CFLAGS) -DCPPUNIT_HAVE_RTTI=0
test_test_util_CXXFLAGS = $(AM_CXXFLAGS) -Wno-error=deprecated-declarations