aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2014-04-30 21:49:03 +0200
committerMax Kellermann <max@duempel.org>2014-05-11 14:49:36 +0200
commitee2afb35dd715d9f34a938cd54ed02a3c0091a78 (patch)
tree539c28b74d2bf1b78b793ea730b706b5bd108829 /Makefile.am
parent0adcda387a276f5fcc24e8a3b9d344a736738a4a (diff)
downloadmpd-ee2afb35dd715d9f34a938cd54ed02a3c0091a78.tar.gz
mpd-ee2afb35dd715d9f34a938cd54ed02a3c0091a78.tar.xz
mpd-ee2afb35dd715d9f34a938cd54ed02a3c0091a78.zip
Makefile.am: add variable NFS_SOURCES
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 5 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index a7a7bef1f..c982bf3c6 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -506,6 +506,9 @@ SMBCLIENT_SOURCES = \
src/lib/smbclient/Mutex.cxx src/lib/smbclient/Mutex.hxx \
src/lib/smbclient/Init.cxx src/lib/smbclient/Init.hxx
+NFS_SOURCES = \
+ src/lib/nfs/Domain.cxx src/lib/nfs/Domain.hxx
+
if ENABLE_DATABASE
noinst_LIBRARIES += libstorage.a
@@ -533,7 +536,7 @@ endif
if ENABLE_NFS
libstorage_a_SOURCES += \
- src/lib/nfs/Domain.cxx src/lib/nfs/Domain.hxx \
+ $(NFS_SOURCES) \
src/storage/plugins/NfsStorage.cxx src/neighbor/plugins/NfsStorage.hxx
endif
@@ -1072,7 +1075,7 @@ endif
if ENABLE_NFS
libinput_a_SOURCES += \
- src/lib/nfs/Domain.cxx src/lib/nfs/Domain.hxx \
+ $(NFS_SOURCES) \
src/input/plugins/NfsInputPlugin.cxx src/input/plugins/NfsInputPlugin.hxx
endif