aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorAndrée Ekroth <andree.ekroth@gmail.com>2014-01-12 21:40:29 +0100
committerMax Kellermann <max@duempel.org>2014-01-13 11:14:19 +0100
commitea771c17c55395b34d8ee3f8073a89d401c85835 (patch)
tree3ee0dc6192b403baa7a1a4a03d7bc8b72221a60b /Makefile.am
parent65ebfb16c90f7c0921983009775b1a2414371d94 (diff)
downloadmpd-ea771c17c55395b34d8ee3f8073a89d401c85835.tar.gz
mpd-ea771c17c55395b34d8ee3f8073a89d401c85835.tar.xz
mpd-ea771c17c55395b34d8ee3f8073a89d401c85835.zip
Shine encoding plugin
This encoding plugin features a fixed-point mp3 encoder, with faster encoding on architectures without a FPU. Right now the encoder is limited to stereo and 16 bit depth. The bitrate and sample rate can be modified in audio_output. audio_output { type "httpd" name "My shine stream" encoder "shine" port "8000" format "44100:16:2" bitrate "320" # default: 128 }
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index d45833c8a..c367ca455 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -722,6 +722,7 @@ libencoder_plugins_a_CPPFLAGS = $(AM_CPPFLAGS) \
$(TWOLAME_CFLAGS) \
$(patsubst -I%/FLAC,-I%,$(FLAC_CFLAGS)) \
$(OPUS_CFLAGS) \
+ $(SHINE_CFLAGS) \
$(VORBISENC_CFLAGS)
ENCODER_LIBS = \
@@ -730,6 +731,7 @@ ENCODER_LIBS = \
$(TWOLAME_LIBS) \
$(FLAC_LIBS) \
$(OPUS_LIBS) \
+ $(SHINE_LIBS) \
$(VORBISENC_LIBS)
libencoder_plugins_a_SOURCES = \
@@ -780,6 +782,12 @@ libencoder_plugins_a_SOURCES += \
src/encoder/FlacEncoderPlugin.cxx src/encoder/FlacEncoderPlugin.hxx
endif
+if ENABLE_SHINE_ENCODER
+libencoder_plugins_a_SOURCES += \
+ src/encoder/ShineEncoderPlugin.cxx \
+ src/encoder/ShineEncoderPlugin.hxx
+endif
+
else
ENCODER_LIBS =
endif