aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2009-03-12 18:34:37 +0100
committerMax Kellermann <max@duempel.org>2009-03-12 18:34:37 +0100
commite9cbb6be3f7c0a13425fdb542db619452668a6b5 (patch)
tree4a420ff03583d0cccc37d1e250685e6ea26f3b9f /Makefile.am
parent9feaedd799cf68173700f3d390c559ee840a430a (diff)
downloadmpd-e9cbb6be3f7c0a13425fdb542db619452668a6b5.tar.gz
mpd-e9cbb6be3f7c0a13425fdb542db619452668a6b5.tar.xz
mpd-e9cbb6be3f7c0a13425fdb542db619452668a6b5.zip
audio: moved mixer functions to mixer_control.c
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am9
1 files changed, 7 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 6133fc7c9..7658fed17 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -80,6 +80,7 @@ mpd_headers = \
src/ls.h \
src/main.h \
src/mixer_api.h \
+ src/mixer_control.h \
src/event_pipe.h \
src/daemon.h \
src/normalize.h \
@@ -151,7 +152,7 @@ src_mpd_SOURCES = \
$(DECODER_SRC) \
$(ENCODER_SRC) \
$(OUTPUT_API_SRC) $(OUTPUT_SRC) \
- $(MIXER_SRC) \
+ $(MIXER_API_SRC) $(MIXER_SRC) \
src/notify.c \
src/audio.c \
src/audio_parser.c \
@@ -453,9 +454,12 @@ OUTPUT_API_SRC = \
OUTPUT_SRC = \
src/output/null_plugin.c
-MIXER_SRC = \
+MIXER_API_SRC = \
+ src/mixer_control.c \
src/mixer_api.c
+MIXER_SRC =
+
if HAVE_ALSA
OUTPUT_SRC += src/output/alsa_plugin.c
MIXER_SRC += src/mixer/alsa_mixer.c
@@ -592,6 +596,7 @@ test_run_output_SOURCES = test/run_output.c \
src/timer.c \
src/output_init.c src/output_list.c \
$(ENCODER_SRC) \
+ src/mixer_api.c \
$(MIXER_SRC) \
$(OUTPUT_SRC)