aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2009-04-10 09:14:12 +0200
committerMax Kellermann <max@duempel.org>2009-04-10 09:14:12 +0200
commite823e78d0f976d738a7031267e0c8aa5bdc90d2e (patch)
tree93b0ac1f16770a91465d200f07ab87d39b1156eb /Makefile.am
parent57cf984aae6470bbf3f61581ff5d3d031115946d (diff)
downloadmpd-e823e78d0f976d738a7031267e0c8aa5bdc90d2e.tar.gz
mpd-e823e78d0f976d738a7031267e0c8aa5bdc90d2e.tar.xz
mpd-e823e78d0f976d738a7031267e0c8aa5bdc90d2e.zip
test: added configuration file reader
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 8a559adc1..77885a363 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -576,12 +576,20 @@ sparse-check:
if ENABLE_TEST
noinst_PROGRAMS = \
+ test/read_conf \
test/run_decoder \
test/read_tags \
test/run_encoder \
test/run_output \
test/software_volume
+test_read_conf_CPPFLAGS = $(AM_CPPFLAGS) \
+ $(GLIB_CFLAGS)
+test_read_conf_LDADD = $(MPD_LIBS) \
+ $(GLIB_LIBS)
+test_read_conf_SOURCES = test/read_conf.c \
+ src/conf.c src/buffer2array.c src/utils.c
+
test_run_decoder_CPPFLAGS = $(AM_CPPFLAGS) \
$(ID3TAG_CFLAGS) \
$(INPUT_CFLAGS) $(DECODER_CFLAGS)