aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2014-12-03 21:39:45 +0100
committerMax Kellermann <max@duempel.org>2014-12-04 09:14:28 +0100
commite69bef3ce389967b8239648e4b9eaec42217bc95 (patch)
tree603870b6d042017c7a93f1909afc91395cf1415b /Makefile.am
parentc1c0fc79bcdc9caabe42fc3716ea2e2ea7b3eb3d (diff)
downloadmpd-e69bef3ce389967b8239648e4b9eaec42217bc95.tar.gz
mpd-e69bef3ce389967b8239648e4b9eaec42217bc95.tar.xz
mpd-e69bef3ce389967b8239648e4b9eaec42217bc95.zip
util/SplitString: new utility class
Replaces GLib's g_strsplit().
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index a79c18172..4aa1061e5 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -375,6 +375,7 @@ libutil_a_SOURCES = \
src/util/NumberParser.hxx \
src/util/StringUtil.cxx src/util/StringUtil.hxx \
src/util/DivideString.cxx src/util/DivideString.hxx \
+ src/util/SplitString.cxx src/util/SplitString.hxx \
src/util/FormatString.cxx src/util/FormatString.hxx \
src/util/Tokenizer.cxx src/util/Tokenizer.hxx \
src/util/TextFile.hxx \
@@ -2002,6 +2003,7 @@ endif
test_test_util_SOURCES = \
test/DivideStringTest.hxx \
+ test/SplitStringTest.hxx \
test/UriUtilTest.hxx \
test/TestCircularBuffer.hxx \
test/test_util.cxx