aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2015-06-22 21:29:29 +0200
committerMax Kellermann <max@duempel.org>2015-06-22 22:12:08 +0200
commite12bd00b474fd2e748067eee2e3289a060097b43 (patch)
tree3638fc377e0ac8dbcabce2336dc0833b237152a0 /Makefile.am
parent50eac9b49e8171cd0f217fca2ec7e673f191d0c7 (diff)
downloadmpd-e12bd00b474fd2e748067eee2e3289a060097b43.tar.gz
mpd-e12bd00b474fd2e748067eee2e3289a060097b43.tar.xz
mpd-e12bd00b474fd2e748067eee2e3289a060097b43.zip
test/TestFs: new unit test for libfs.a
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am9
1 files changed, 9 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 349fb4c37..b230e2b66 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1514,6 +1514,7 @@ C_TESTS = \
test/test_pcm \
test/test_protocol \
test/test_queue_priority \
+ test/TestFs \
test/TestIcu
if ENABLE_CURL
@@ -2164,6 +2165,14 @@ test_test_queue_priority_LDADD = \
libutil.a \
$(CPPUNIT_LIBS)
+test_TestFs_SOURCES = \
+ test/TestFs.cxx
+test_TestFs_CPPFLAGS = $(AM_CPPFLAGS) $(CPPUNIT_CFLAGS) -DCPPUNIT_HAVE_RTTI=0
+test_TestFs_CXXFLAGS = $(AM_CXXFLAGS) -Wno-error=deprecated-declarations
+test_TestFs_LDADD = \
+ $(FS_LIBS) \
+ $(CPPUNIT_LIBS)
+
test_TestIcu_SOURCES = \
test/TestIcu.cxx
test_TestIcu_CPPFLAGS = $(AM_CPPFLAGS) $(CPPUNIT_CFLAGS) -DCPPUNIT_HAVE_RTTI=0