aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2014-07-14 19:03:45 +0200
committerMax Kellermann <max@duempel.org>2014-07-14 19:05:01 +0200
commite0ca4347beb2e2e7235e16c4555d426c7d923468 (patch)
tree2c9babe8953e794c410b861d149f8f208ba93a6e /Makefile.am
parente65d9408eecf40af1689dbfbc4336f97ea68ec13 (diff)
downloadmpd-e0ca4347beb2e2e7235e16c4555d426c7d923468.tar.gz
mpd-e0ca4347beb2e2e7235e16c4555d426c7d923468.tar.xz
mpd-e0ca4347beb2e2e7235e16c4555d426c7d923468.zip
Android: generate icon from SVG
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am11
1 files changed, 8 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 7f9ef3e93..23b5201b6 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -276,8 +276,9 @@ libmpd.so: $(filter %.a,$(src_mpd_LDADD)) libmain.a
android/build/build.xml: android/AndroidManifest.xml
rm -rf android/build
- mkdir -p android/build/include
- ln -s $(srcdir)/android/AndroidManifest.xml $(srcdir)/android/custom_rules.xml $(srcdir)/android/src $(srcdir)/android/res android/build
+ mkdir -p android/build/include android/build/res
+ ln -s $(srcdir)/android/AndroidManifest.xml $(srcdir)/android/custom_rules.xml $(srcdir)/android/src android/build
+ ln -s $(srcdir)/android/res/values android/build/res
$(ANDROID_SDK)/tools/android update project --path android/build --target android-17
android/build/bin/classes/org/musicpd/Bridge.class: android/src/Bridge.java android/build/build.xml
@@ -293,7 +294,11 @@ android/build/libs/armeabi-v7a/libmpd.so: libmpd.so android/build/build.xml
rm -f $@
$(STRIP) -o $@ $<
-android/build/bin/Main-debug.apk: android/build/build.xml android/build/libs/armeabi-v7a/libmpd.so
+android/build/res/drawable/icon.png: mpd.svg
+ mkdir -p $(@D)
+ rsvg-convert --width=48 --height=48 $< -o $@
+
+android/build/bin/Main-debug.apk: android/build/build.xml android/build/res/drawable/icon.png android/build/libs/armeabi-v7a/libmpd.so
cd android/build && ant nodeps debug
android/build/bin/Main-release-unsigned.apk: android/build/build.xml android/build/libs/armeabi-v7a/libmpd.so